Game-show Java applets at uproar.com hangs Mozilla

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Keith Bowes, Assigned: Joshua Xia)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011010
Netscape6/6.1b1
BuildID:    2001120808

Game-show Java applets at uproar.com hangs Mozilla.  But other games on the site
(such as Solitaire) work.  This happens with both versions 1.3.1_01a and 1.4.0
Beta 3 of Sun's Java plug-in on both Windows ME and Windows XP.  This seems to
be a problem with Mozilla because these applets work fine in Internet Explorer 6
on XP with Sun's Java plug-in set as the handler of applets.

Reproducible: Always
Steps to Reproduce:
1. Go to one of the game show game pages on uproar.com (such as
http://www.uproar.com/games/familyfeud_module.asp).
2. Wait a while as the applet tries to load.

Actual Results:  The applet just stops and often hangs the browser.  With
version 1.3.1_01a of the Java plug-in, the gray box is displayed indefinitely;
with version 1.4.0 Beta 3, the string "Loaded: Timer_loop.au" is displayed for a
while before the Mozilla window stops responding.

Expected Results:  The applet should load.

Comment 1

17 years ago
confirming on Linux using build 2001120812 + JRE 1.3.1:

Doesn't hang though, but strange sound can be heared from the speakers (!), Java
console:

class uproar.toolkits.MessageLogs.SilentMessageLog: Version 1.13.0
LOG  VERSION: class uproar.toolkits.gamingToolkits.ProductionToolkitVer3 = 3.1.0
LOG  VERSION: class uproar.clientBase.agt.Cradle = 5.1.0
LOG  VERSION: class uproar.toolkits.fileConfigReader.FileConfigReader = 1.14.0
LOG  VERSION: class uproar.toolkits.fileConfigReader.CachingFileConfigReader = 1.1.0
LOG  VERSION: class uproar.console.singleGameConsole.Console = 5.1.0
LOG  VERSION: class uproar.toolkits.exampleGameLists.GameListProducerVer1 = 1.14.0
LOG  VERSION: class uproar.AdDisplayer.DhtmlAdDisplayer = 5.1.0
LOG  VERSION: class uproar.AdDisplayer.DhtmlDCAdDisplayer = 1.22.0
LOG  VERSION: class uproar.clientBase.layerManager.LayerManager1.19.0
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
	at uproar.clientLib.layerManager.LayerManager.getLayerManager(LayerManager.java)
	at uproar.toolkits.adDisplayer.DhtmlAdDisplayer.<init>(DhtmlAdDisplayer.java)
	at
uproar.toolkits.adDisplayer.DhtmlDCAdDisplayerVer2.<init>(DhtmlDCAdDisplayerVer2.java)
	at
uproar.toolkits.gamingToolkits.ProductionToolkitVer3.createAdDisplayer(ProductionToolkitVer3.java)
	at uproar.clientBase.agt.Cradle.getAdDisplayer(Cradle.java)
	at uproar.console.singleGameConsole.Console.init(Console.java)
	at sun.applet.AppletPanel.run(AppletPanel.java:344)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:484)
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[Finalizer,8,system]
OJIPlugin releasePipe - exiting spont monitor
LOG  VERSION: class uproar.toolkits.ObjectLoaders.ObjectLoaderVer1 = 1.14.0
LOG  VERSION: class uproar.toolkits.AssetLoaders.ZippedAssetLoader = 1.14.0
LOG  VERSION: class uproar.AdDisplayer.LoadAdDisplayer = 5.1.0
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
	at uproar.clientLib.layerManager.LayerManager.getLayerManager(LayerManager.java)
	at uproar.toolkits.adDisplayer.DhtmlAdDisplayer.<init>(DhtmlAdDisplayer.java)
	at
uproar.toolkits.adDisplayer.DhtmlDCAdDisplayerVer2.<init>(DhtmlDCAdDisplayerVer2.java)
	at uproar.toolkits.adDisplayer.LoadAdDisplayer.<init>(LoadAdDisplayer.java)
	at
uproar.toolkits.gamingToolkits.ProductionToolkitVer3.createLoadAdDisplayer(ProductionToolkitVer3.java)
	at uproar.clientBase.agt.Cradle.getLoadAdDisplayer(Cradle.java)
	at uproar.console.singleGameConsole.Console.start(Console.java)
	at sun.applet.AppletPanel.run(AppletPanel.java:358)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:484)
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
LOG  VERSION: class uproar.toolkits.AssetLoaders.GifImageDecoder = 1.14.0
LOG  VERSION: class uproar.familyFeud.FamilyFeud = 1.30.0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-uproar.console.singleGameConsole.Console.class,4,http://ff.uproar.com/games/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[Finalizer,8,system]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[Finalizer,8,system]
OJIPlugin releasePipe - exiting spont monitor
java.lang.NullPointerException
	at uproar.toolkits.adDisplayer.DhtmlAdDisplayer.a(DhtmlAdDisplayer.java)
	at uproar.toolkits.adDisplayer.LoadAdDisplayer.displayAds(LoadAdDisplayer.java)
	at uproar.console.singleGameConsole.Console.start(Console.java)
	at sun.applet.AppletPanel.run(AppletPanel.java:358)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:484)
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[Finalizer,8,system]
OJIPlugin releasePipe - exiting spont monitor
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread

OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[Finalizer,8,system]
OJIPlugin releasePipe - exiting spont monitor
LOG  VERSION: class uproar.toolkits.atm.IcoinTeller = 1.14.0
LOG  VERSION: class uproar.toolkits.atm.UserInfoThread = 1.0.0
LOG  VERSION: class uproar.toolkits.atm.MyUserInfo = 3.1.0
LOG  VERSION: class uproar.toolkits.fileConfigReader.PollingServerMessenger = 1.14.0
LOG  VERSION: class
uproar.toolkits.fileConfigReader.WaitingPollingServerMessenger = 3.1.0
LOG  VERSION: class uproar.clientBase.agt.Sound = 1.14.0
Severity: critical → normal
OS: Windows XP → All

Updated

17 years ago
Severity: normal → critical
Keywords: hang

Comment 2

17 years ago
Marking NEW to get a wider audience.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I saw the same behaviour as specified in comment #1.
The reason of occuring of 'null pointer exception' is
the code in file mozilla/modules/oji/src/lcglue.cpp: lines 464-469

        jsSecurityContext->GetOrigin(jsorigin,buflen);
        javaSecurityContext->GetOrigin(jvorigin,buflen);

        if (nsCRT::strcasecmp(jsorigin,jvorigin)) {
            return PR_FALSE;
        }

Since the java archive is obtained from http://ff.uproar.com
and the name of site is http://www.uproar.com hence,
the origins of java and javascript are not equal. This causes
non-initializing of javascript from java and hence applet
throws "NULL pointer" exceptions.

The code in lcglue.cpp has been developed by Patrick Beard
to fix bug #60018. 

To beard: Patrick would you please comment this code in lcglue.cpp ?
From my point of view this bug (#114350) would be resolved either as
INVALID or as WONTFIX ?

When I commented out code in lcglue.cpp browser didn't hang.

Comment 4

16 years ago
Any changes to lcglue.cpp should be integrated on top of the patch in bug 
#124053, which removes a bunch of dead code.
Depends on: 124053

Updated

16 years ago
QA Contact: pmac → petersen
(Assignee)

Comment 5

16 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 6

16 years ago
WFM on Linux(RH8.0) mozilla 1.2 JRE 1.4.1_01
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
It doesn't hang with the newest version, but the applet still doesn't work.  I
get a lot of errors in the console and when it's finished, all I see is a red X
in the corner.  At least, that's what happens for me.

Comment 8

16 years ago
I got following errors:
java.lang.NullPointerException
	at uproar.clientLib.layerManager.c.getLayerManager(Unknown Source)
	at uproar.toolkits.adDisplayer.d.<init>(Unknown Source)
	at uproar.toolkits.adDisplayer.c.<init>(Unknown Source)
	at
uproar.toolkits.gamingToolkits.ProductionToolkitVer3.createAdDisplayer(Unknown
Source)
	at uproar.clientBase.agt.s.getAdDisplayer(Unknown Source)
	at uproar.console.singleGameConsole.Console.init(Unknown Source)
	at sun.applet.AppletPanel.run(AppletPanel.java:347)
	at java.lang.Thread.run(Thread.java:536)

I think it's from the applet. And the applet's developer should check what's
happening.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.