Facebook input forms not behaving properly

RESOLVED WORKSFORME

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: kar, Assigned: esawin)

Tracking

39 Branch
All
Android
Points:
---

Firefox Tracking Flags

(fennec41+)

Details

(Whiteboard: FB#6525863)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8578707 [details]
2015-03-17 15.16.56.png

I try to comment in a Facebook free text field (comment box) and it gets all garbled. This is whether I use swype or try to tap each letter out. Has been going on for a while, and was hoping it would get better - but it hasn't (yet).
What keyboard?
Flags: needinfo?(krudnitski)
(Reporter)

Comment 2

3 years ago
This is on my nexus 5 using English (UK) Google Keyboard (and happens when I also use Swype or tap (but with the Swype keyboard still being the selected one)
Flags: needinfo?(krudnitski)
(Assignee)

Comment 3

3 years ago
This reproduces only on the non-mobile version of the site when the user explicitly requests the desktop version (tested on Nexus 5 Android L, Google US, UK and German keyboard and Swype).

I'll look into it, but in the meanwhile, using the mobile version is a workaround.
(Assignee)

Updated

3 years ago
Assignee: nobody → esawin
(Reporter)

Comment 4

3 years ago
Um - I *only* use the mobile version... I wasn't using the desktop version (see my screenshot :) )
(Assignee)

Comment 5

3 years ago
Created attachment 8578894 [details]
fb.png
(Assignee)

Comment 6

3 years ago
The mobile version served to me does look different to yours (see comment 5) and doesn't show the bug.
But I will look into fixing it for the desktop version, chances are it's caused by the same issue.
Facebook is rolling out a new UI for the msite. Going to poke some FBers about it.

Comment 8

3 years ago
(In reply to Kevin Brosnan [:kbrosnan] from comment #7)
> Facebook is rolling out a new UI for the msite. Going to poke some FBers
> about it.

When is this planned
Facebook does staged roll outs of features. How Facebook chooses people for the test groups is mostly a mystery to me.

Did a video of the behavior I am seeing at http://people.mozilla.org/~kbrosnan/tmp/1144174/facebook.mp4
Whiteboard: FB#6525863
(Assignee)

Comment 10

3 years ago
It's reproducing on Google Chrome with the desktop version, so that's most likely a site issue.
Duplicate of this bug: 1143282
(Assignee)

Comment 12

3 years ago
STR:
1. Open https://www.facebook.com (and request desktop site version).
2. Focus on the comment field of a post.
3. Type "A " (the space is important).
4. Tap backspace multiple times to delete the written text.

Expected:
Text is being delete.

Actual:
It depends. The first delete action usually has no effect (cursor position remains unchained).
The second delete may delete the whitespace. In this case, the third delete will delete the "A" and the text is immediately being placed back (the original "A " reappears).
The deletes following this may duplicate the whole text repeatedly similar to bug 1134209.

Notes:
This is not reproducing for me in the "Update Status" field nor on the mobile version in general. However, users from other locales report the issue on the mobile version, too.

Since Google Chrome shows very similar issues on the desktop site, I'm inclined to think that it's an issue with the site, however, we are also showing similar effects on other sites (bug 1134209, bug 1117051), which makes me wonder if there is a general issue on our side here.
tracking-fennec: ? → 41+
I can reproduce using Chrome for Android with desktop Facebook, though poorly the magnifying glass gets in the way. I cannot reproduce using Chrome for Android and the m-site.
(Reporter)

Comment 14

3 years ago
so on today's nightly, I start typing and it takes seconds before anything appears on the m-site
This seems to be resolved. Kar if you see the text not showing open a new bug. It seems rather different than the initial issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.