Closed Bug 1144465 Opened 7 years ago Closed 2 years ago

Text inside ruby is not bidi reordered

Categories

(Core :: Layout: Ruby, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: xidorn, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 1141931 intends to fix bidi reordering of ruby frames themselves, but not the frames inside ruby base or ruby text.

Since rtl text is normally won't be put inside ruby, this bug is in lower priority.
Duplicate of this bug: 1451876
Component: Layout: Block and Inline → Layout: Ruby
Duplicate of this bug: 1587937
Flags: needinfo?(xidorn+moz)

I have a working build now. Still need to do some more checking and testing, and clean up the code a bit.

Assignee: nobody → xidorn+moz
Flags: needinfo?(xidorn+moz)

This commit changes IsBidiLeaf to mark ruby boxes not a bidi leaf, since
conceptually they are not. I auditted all uses of it, and I believe it
makes more sense this way.

Pushed by mozilla@upsuper.org:
https://hg.mozilla.org/integration/autoland/rev/ba1f9a1d9e6f
Resolve bidi inside ruby. r=jfkthame
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/20980 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.