Closed Bug 1451876 Opened 4 years ago Closed 4 years ago

Reverse arabic/persian words inside html ruby tags

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1144465

People

(Reporter: hamidebadi1987, Unassigned)

Details

(Keywords: rtl)

Attachments

(1 file)

Attached file hello.html
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.168 Safari/537.36 OPR/51.0.2830.40

Steps to reproduce:

I have the same text inside <p> and <rt>, but the letters appear in the reverse order in Firefox when placed inside the ruby tag (Even if you don't know the languages, you can still see that the words look different.):
I'm guessing this is a Firefox browser bug (I have tried it with no problem on Chrome and Opera and IE).


Actual results:

Words in <rt> tag appears in the reverse order.


Expected results:

To see the same looking word both in <p> and <rt> tag.
Component: Untriaged → Layout: Text
Product: Firefox → Core
Version: 59 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: rtl
Component: Layout: Text → Layout
Yeah, bidi reorder isn't applied in ruby, which is a known issue... We probably should fix it if there are people actually using it that way.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144465
You need to log in before you can comment on or make changes to this bug.