[Bluetooth2] Visible to all should turn off after 2 mins

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: twen, Assigned: iliu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Description
Visible to all should turned off after 2 minutes.

*** Steps to Reproduce
1. Go to Settings -> Bluetooth
2. Tap on "Visible to all" toggle to turn on
3. Wait for 2 minutes

*** Expected Results
"Visible to all" will turn-off after 2-minutes

*** Actual Results
"Visible to all" stays on.


*** Build
Gaia-Rev        4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko-Rev       
Build-ID        20150317153105
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150316.195035
FW-Date         Mon Mar 16 19:50:48 EDT 2015
Bootloader      L1TC000118D0

See bug 1130946 for gecko commit.
(Reporter)

Updated

4 years ago
Summary: [Bluetooth2] Visible to all should turned off after 2 mins → [Bluetooth2] Visible to all should turn off after 2 mins
(Reporter)

Updated

4 years ago
Blocks: 1130946
(Assignee)

Updated

4 years ago
Assignee: nobody → iliu

Updated

4 years ago
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Updated

4 years ago
Component: Bluetooth → Gaia::Settings
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Created attachment 8584330 [details] [review]
[gaia] ian-liu:bluetooth/bug1144532_timer_to_disable_visibility > mozilla-b2g:master
Comment on attachment 8584330 [details] [review]
[gaia] ian-liu:bluetooth/bug1144532_timer_to_disable_visibility > mozilla-b2g:master

Arthur, could you please help to review my patch? The patch is arming to complete disabling visibility automatically as Bluetooth code base v1. Thanks.
Attachment #8584330 - Flags: review?(arthur.chen)
Since I'm working on the patch, I find out the adapter.discoverable property is unexpected for me. File a bug for tracking bug 1148314.
(In reply to Ian Liu [:ianliu] from comment #2)
> Comment on attachment 8584330 [details] [review]
> [gaia] ian-liu:bluetooth/bug1144532_timer_to_disable_visibility >
> mozilla-b2g:master
> 
> Arthur, could you please help to review my patch? The patch is arming to
> complete disabling visibility automatically as Bluetooth code base v1.
> Thanks.

Note: The finial user story will be implemented via bug 1121913. Mark it see also.
See Also: → bug 1121913
Comment on attachment 8584330 [details] [review]
[gaia] ian-liu:bluetooth/bug1144532_timer_to_disable_visibility > mozilla-b2g:master

Good work! r=me.
Attachment #8584330 - Flags: review?(arthur.chen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Depends on: 1152675
You need to log in before you can comment on or make changes to this bug.