CGI query string posts don't work reliably

VERIFIED DUPLICATE of bug 7533

Status

()

Core
HTML: Parser
P3
major
VERIFIED DUPLICATE of bug 7533
19 years ago
19 years ago

People

(Reporter: semperubisububi, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
For instance go to a room on this page (which uses them heavily hence why I use
it as an example), Go to the elevator for instance then goto "The BAbble"... It
will drop the query string.  This happens on other pages.  I actually went to
this one to see if the continuous feed worked...it did.  (some versions of
netscape on linux didnt!...good work!)

Updated

19 years ago
Assignee: rickg → pollmann

Comment 1

19 years ago
Eric -- please take a look.
(Assignee)

Comment 2

19 years ago
I couldn't find "The BAbble" inside the elevator.
This may be bug 10128, which was fixed on Friday.
Can you pull the latest nightly build and see if you are still expreniencing
this bug.  If so, please provide a test case.  Thanks!
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

19 years ago
I tested every link on this page in today's build and it worked as expected.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 4

19 years ago
I downloaded the daily build just now and tried it (I'm not at home so I have
to do this in windows today).  Doesn't work.  Here's how to test it with this
webpage.  I also did this somewhere else but I don't remember I'll get back to
you on that if you cant verify it here.

http://www.hotelchat.com/cgi-bin/displayroom?ROOM=20

Then click on the combo, select Babble, click Submit.  You'll get an error:

cgi-lib.pl: Unknown Content-type: application/x-www-form-urlencoded;
charset=ISO-8859-1

This apears to happen in part because the query string is gone. This has no
problems in both IE 4.0, Netscape 4.61 (on windows and linux).
(Reporter)

Comment 5

19 years ago
Other sites that behave the same.  www.hotmail.com (try to log in, it will
basically put you back at the login screen as if nothing happened),
webmail.bellsouth.net, and http://bugzilla.mozilla.org/query.cgi <G>.  The last
tries to get you to download a plugin.  I think these are all related somehow.
It seems to be related to cgi and a query string.

Updated

19 years ago
Resolution: INVALID → ---

Comment 6

19 years ago
Clearing Invalid resolution due to reopen.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
This is a dup of bug 7533 - the content type string that we are posting is
different than that posted by IE or Nav.  Make sure to check out these two URLs
for more information on this issue:

http://bugzilla.mozilla.org/show_bug.cgi?id=7533
http://developer.netscape.com/viewsource/krock_v5.html

*** This bug has been marked as a duplicate of 7533 ***
(Reporter)

Comment 8

19 years ago
I think this is REALLY dangerous. !! The pages work fine in IE 5!!!  Secondly,
if anyone were to attempt to use Mozilla in an corporate enviroment that used
Front Page (this is relatively common) for authoring, it posts that content
type every time.  I'll agree that this is very nice an theoretically correct
and all of that. But no one will use a browser that says "sorry tell the author
to change their page to work with this browser".  So obvioulsy if the goal is
to have actual end-users of this software then this is something that will have
to be changed.  Consider, Microsoft is going to say "here's a browser that runs
all your existing pages and does this gee-wiz" and Netscape/Mozilla are going
to say "fix your web pages so they'll work with out browser".  What do you
think Joe blow-customer will choose?  Think about your customer.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
verified dup...see Bug 7533
You need to log in before you can comment on or make changes to this bug.