File|Save as File broken in newmssg/reply/forward in compose window

VERIFIED FIXED in mozilla0.9.8

Status

MailNews Core
Composition
P1
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Jim Avera, Assigned: Jean-Francois Ducarroz)

Tracking

({regression})

Trunk
mozilla0.9.8
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: se-radar, Have fix)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011207
BuildID:    2001120708

While composing a mail message,
File->Save as File... does not appear to do anything.
A file-selection dialog does not appear.

Reproducible: Always
Steps to Reproduce:
1.Start   mozilla -mail
2.Open an existing inbound message
3.Click Reply
4.Do File->Save as File...

Actual Results:  Nothing happens

Expected Results:  File-selection dialog should appear
not composition
Assignee: ducarroz → sspitzer
Status: UNCONFIRMED → NEW
Component: Composition → Mail Window Front End
Ever confirmed: true
QA Contact: sheelar → esther

Comment 2

17 years ago
Changing os to all. Nominating 
Save as file does not bring up the file selection dlg only when you are trying
to save replied or forwarded message

Save as file brings up the file selection dlg from the 3 pane, stand alone
message window.
Severity: normal → minor
Keywords: nsbeta1
OS: Linux → All
QA Contact: esther → sheelar

Comment 3

17 years ago
changing the summary
Summary: File->Save as File... broken → File|Save as File broken in newmssg/reply/forward in compose window

Comment 4

17 years ago
Bug 114874 is a recent regression which has problem saving page. 
Assignee: sspitzer → ducarroz
Component: Mail Window Front End → Composition
(Assignee)

Comment 5

17 years ago
Here is the error:

SaveAsFile from XUL
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "editorShell.saveDocument is not a function"
{file: "chrome://messenger/content/messengercompose/
MsgComposeCommands.js" line: 1677}]' when calling method:
[nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIP
T_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goDoCommand :: line 67"  data: yes]
************************************************************
An error occurred executing the cmd_saveAsFile command

Looks like the editor api as changed! reassign to varada
Assignee: ducarroz → varada
Target Milestone: --- → mozilla0.9.9
Severity: minor → normal
Keywords: regression
Hardware: PC → All
(Reporter)

Comment 6

17 years ago
Save As->File also does not work when composing a brand-new mail
message started with File->New Message (in Linux build 2001123108).

That is, the bug exists not just when starting with Reply
or a forwarded message.

(File->Save As->File... does not pop up a dialog; nothing on stdout/stderr)

Comment 7

17 years ago
Reporter,
If you see the summary, I did include newmssg in which means it save as file is
not working when new message compose.  

Comment 8

17 years ago
*** Bug 119313 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Severity: normal → major
Whiteboard: se-radar

Comment 9

17 years ago
reassigning to ducarroz.
Assignee: varada → ducarroz
Priority: -- → P1
(Assignee)

Comment 10

17 years ago
probably an editor api change that hasn't reported in msg compose...
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Whiteboard: se-radar → se-radar, Have fix
(Assignee)

Comment 11

17 years ago
Created attachment 65059 [details] [diff] [review]
Proposed fix, v1

Comment 12

17 years ago
Comment on attachment 65059 [details] [diff] [review]
Proposed fix, v1

r=cavin.
Attachment #65059 - Flags: review+

Comment 13

17 years ago
Comment on attachment 65059 [details] [diff] [review]
Proposed fix, v1

sr=bienvenu
Attachment #65059 - Flags: superreview+

Comment 14

17 years ago
Adding nsbeta1 keyword to all regressions so they *get some love* and attention.

Comment 15

17 years ago
Fixing a broken feature seems worth getting into 0.9.8 so moving back.
Keywords: nsbeta1 → nsbeta1+
Target Milestone: mozilla0.9.9 → mozilla0.9.8
a=blizzard on behalf of drivers for 0.9.8
Keywords: mozilla0.9.8+
(Assignee)

Comment 17

17 years ago
Checked in and fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
Build id: 2002-01-26-06 win98, linux
2002-01-24-06 mac os 10.1

verified save as file from 3 pane, stand alone window, new message from compose
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.