If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 1108834
3 years ago
3 years ago

People

(Reporter: Martin Husemann, Unassigned)

Tracking

36 Branch
Sun
NetBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
After applying a patch close to the one suggested in bug 1105087 which makes the gfx part build, the build for NetBSD/sparc64 now fails like this:

c++ -o Unified_cpp_js_src5.o -c  -I../../dist/system_wrappers -include /usr/pkgobj/www/firefox/work/mozilla-release/config/gcc_hidden.h 
-DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX='"lib"' -DDLL_SUFFIX='".so"' -DMOZ_GLUE_IN_PROGRAM -DAB_CD= -DNO_NSPR_10_SUPPORT -I/usr/pkg
obj/www/firefox/work/mozilla-release/js/src -I. -I/usr/pkg/include -I/usr/pkg/include -I../../dist/include   -I/usr/pkg/include/nspr    
    -fPIC -DPIC  -DPNG_NO_ASSEMBLER_CODE -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/nspr -I/usr/pkg/include/nss/nss -I/usr/X11
R7/include -I/usr/X11R7/include/libdrm -I/usr/X11R7/include/freetype2 -DMOZILLA_CLIENT -include ../../js/src/js-confdefs.h -MD -MP -MF .
deps/Unified_cpp_js_src5.o.pp -DPNG_NO_ASSEMBLER_CODE -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/nspr -I/usr/pkg/include/nss/n
ss -I/usr/X11R7/include -I/usr/X11R7/include/libdrm -I/usr/X11R7/include/freetype2 -Wall -Wsign-compare -Wtype-limits -Wno-invalid-offse
tof -O2 -pipe -I/usr/pkg/include -I/usr/include -I/usr/pkg/include/nspr -I/usr/pkg/include/nss/nss -I/usr/X11R7/include -I/usr/X11R7/inc
lude/libdrm -I/usr/X11R7/include/freetype2 -Dunix -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe  -DNDEBUG -DTRIM
MED -g -O2 -fomit-frame-pointer     /usr/pkgobj/www/firefox/work/build/js/src/Unified_cpp_js_src5.cpp
Unified_cpp_js_src6.o
In file included from /usr/pkgobj/www/firefox/work/build/js/src/Unified_cpp_js_src4.cpp:2:0:
/usr/pkgobj/www/firefox/work/mozilla-release/js/src/jit/Ion.cpp: In function 'js::jit::LIRGraph* js::jit::GenerateLIR(js::jit::MIRGenera
tor*)':
/usr/pkgobj/www/firefox/work/mozilla-release/js/src/jit/Ion.cpp:1619:18: error: cannot declare variable 'lirgen' to be of abstract type 'js::jit::LIRGenerator'
     LIRGenerator lirgen(mir, graph, *lir);
                  ^
In file included from /usr/pkgobj/www/firefox/work/mozilla-release/js/src/jit/Ion.cpp:35:0,
                 from /usr/pkgobj/www/firefox/work/build/js/src/Unified_cpp_js_src4.cpp:2:
/usr/pkgobj/www/firefox/work/mozilla-release/js/src/jit/Lowering.h:31:7: note:   because the following virtual functions are pure within 'js::jit::LIRGenerator':
 class LIRGenerator : public LIRGeneratorSpecific
(Reporter)

Updated

3 years ago
Hardware: x86_64 → Sun
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108834
You need to log in before you can comment on or make changes to this bug.