[RTL][First Time Experience]The Cancel and OK buttons are swapped in Date and Time selector view during FTE.

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
P3
normal
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8579918 [details]
Screenshot_Date&Time selector.png

[1.Description]:
[RTL][v2.2&v3.0][First Time Experience]Flash or reset device, The Cancel and OK buttons are swapped in Date and Time selector view during FTE.
See attachment:Screenshot_Date&Time selector.png

[2.Testing Steps]: 
1.Flash or reset device.
2.Set your phone language to Arabic in FTE.
3.Tap next button untill enter "Date&Time" view.
4.Tap value selector button of Time and Date.
5.Observe the Date and Time selector view.

[3.Expected Result]: 
5.The Cancel and OK buttons should not be swapped and should remain the same position as that in LTR language.

[4.Actual Result]: 
5.The Cancel and OK buttons are swapped.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.093634
Firmware Date          Wed Mar 18 09:36:44 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
Import contacts from Gmail/Outlook/Facebook during FTE, the Select all and Deselect all buttons still be swapped in the Gmail/Outlook/Facebook contacts list.
See attachment:Screenshot_Contacts list.png
(Reporter)

Comment 1

3 years ago
Created attachment 8579919 [details]
Screenshot_Contacts list.png
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
In RTL, FTE buttons should remain the same as LTR in 2.2, because of time constraints.
Triage -- P3
Priority: -- → P3
Wait - just noticed this bug covers 2 issues. Please only cover 1 issue per bug!
Please file a separate issue for the Gmail/Outlook/Facebook contacts list you also describe. thanks
I think we need clarification here. We have different kind of buttons in FTU and other apps. My understanding was the *navigation* buttons are inherently directional and we were keeping those left-to-right. But OK/cancel dialog buttons should be flipped.
Flags: needinfo?(swilkes)
(In reply to Sam Foster [:sfoster] from comment #4)
> ... But OK/cancel dialog buttons should be flipped.

I.e. Attachment #8579918 [details] shows the correct OK/Cancel button arrangement for RTL locales (and this bug is invalid)
See also bug 1142919, where I think the confusion started. Its hard to distinguish navigational buttons from not and seems to be a case-by-case decision on which should be reversed for RTL and which shouldnt.
Correct Sam - and this is confusing in regards to FTE :) Waiting for a confirmation then to make extra sure. thanks!
(FWIW: Stephany mentions "As noted in the spec, FTU is out of scope for 2.2." here: https://bugzilla.mozilla.org/show_bug.cgi?id=1142919#c8 so I would assume this implies all buttons present there as well. BUT that's just me supposing :) )

Comment 9

3 years ago
Yes - unfortunately, FTE could not be changed for 2.2. Elsewhere in the OS, everything is flipped. We know it sucks.
Flags: needinfo?(swilkes)
Whiteboard: MGSEI-RTL-3F

Updated

3 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F,[2.2-nexus-5-l]
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F,[2.2-nexus-5-l] → [2.2-nexus-5-l]
(Reporter)

Comment 10

3 years ago
Created attachment 8647935 [details]
AriesKK_v2.5.png

This issue can be reproduced on latest AriesKK v2.5 build by the same STR in comment 0.
Actual Result:
The Cancel and OK buttons are swapped in Date and Time selector view.
See attachment:AriesKK_v2.5.png
Reproducing rate:10/10

Device:AriesKK v2.5 build
Build ID               20150812230643
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150812.222959
Firmware Date          Wed Aug 12 22:30:07 UTC 2015
Bootloader             s1
(Reporter)

Updated

3 years ago
Blocks: 1181931
If I'm not mistaken, the new specs for 2.5 says that these buttons DO swap, whether navigation or not, so closing INVALID. Don't hesitate to reopen if needed. Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.