[Built-in&System Keyboard]It will input "Y" if we tap "Shift" key after pressing and holding on "Y" key.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: liuyong, Assigned: rudyl)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: 2.2-nexus-5-l)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:[Nexus 5][v2.2&v3.0][Flame2.2]In text field, tap and hold on "Y", then press "Shift" key. The "Y" will be input.
Reproduce rate:5/5
Found time:17:27
Attachment:logcat_1727.txt, 1727.mp4

[2.Testing Steps]: 
1. Luanch Browser.
2. Tap "Y" and hold on it.
3. Tap "Shift" key.

[3.Expected Result]: 
3. According to TC, it should input "y".

[4.Actual Result]: 
3. The "Y" will be input.

[5.Reproduction build]: 
N5_3.0(affected):

Build ID               20150318055750
Gaia Revision          b8051d370ddf4e5bd8e7d8a19fb9eeb5fd6ffb39
Gaia Date              2015-03-18 07:48:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/41a61514461e
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150318.093541
Firmware Date          Wed Mar 18 09:35:58 EDT 2015
Bootloader             HHZ12d

N5_2.2(affected):

Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150318.040241
Firmware Date          Wed Mar 18 04:02:56 EDT 2015
Bootloader             HHZ12d

Flame 2.2(affected):

Build ID               20150318002504
Gaia Revision          306772a58335ac4cad285d27c3805090a8cc6886
Gaia Date              2015-03-17 17:12:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a6f5f4035ea5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150318.040534
Firmware Date          Wed Mar 18 04:05:45 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12886

[8.Note]:
It CAN be repro on Flame 2.2
(Reporter)

Comment 1

4 years ago
Posted file logcat_1727.txt
(Reporter)

Comment 2

4 years ago
Posted video 1727.MP4
FWD to QA keyboard owner
Flags: needinfo?(gchang)
According to multi-touch behavior, the first key should be input first.
NI developer to see if the behavior is changed.
Flags: needinfo?(gchang) → needinfo?(rlu)
I tested this with v2.1 and could not reproduce this, so I think this is a regression.
I suspect this is related to the change we made in Bug 985853.
Flags: needinfo?(rlu)
Keywords: regression
It's a regression.
blocking-b2g: --- → 2.2?
Let's have a regression window investigation. Based on comment 0 and comment 5, v2.1 is unaffected and v2.2/master are, on Flame v18D 1GB.
(In reply to John Lu [:mnjul] [MoCoTPE] from comment #7)
> Based on comment 0 and comment 5, v2.1 is unaffected and v2.2/master are,

are affected, I mean.

Comment 9

4 years ago
Triage: regression, blocking.
Assignee: nobody → rlu
blocking-b2g: 2.2? → 2.2+
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141028193911
Gaia: f74da0ff96f5e6e37be12169b6ca41ab6718e668
Gecko: bd1f60da7096
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141028204307
Gaia: 548b8981f3363fe527b1cb660c0895c6e798fb16
Gecko: f4c2b05f8799
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: f74da0ff96f5e6e37be12169b6ca41ab6718e668
Gecko: f4c2b05f8799

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 548b8981f3363fe527b1cb660c0895c6e798fb16
Gecko: bd1f60da7096

https://github.com/mozilla-b2g/gaia/compare/f74da0ff96f5e6e37be12169b6ca41ab6718e668...548b8981f3363fe527b1cb660c0895c6e798fb16

caused by bug 985853
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Doug, can you take a look at this please? This might have been caused by the landing for bug 985853.

I cannot find an email for Chardis. My apologies if I am need infoing the wrong person here.
Blocks: 985853
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dxue)
I have a patch trying to resolve this issue, so clear the ni.
Status: NEW → ASSIGNED
Flags: needinfo?(dxue)
Comment on attachment 8586612 [details] [review]
[gaia] RudyLu:keyboard/Bug1145072-keyboard_action_queue > mozilla-b2g:master

The solution somehow comes from what we intended to do in bug 1040603, that we will have an action queue for key input.

Tim, could you please help review this change?
Thank you.
Attachment #8586612 - Flags: review?(timdream)
Comment on attachment 8586612 [details] [review]
[gaia] RudyLu:keyboard/Bug1145072-keyboard_action_queue > mozilla-b2g:master

Discussed offline, let's make sure we could trigger feedback synchronizely but queue other stuff.

Please also verify this on 319MB Flame.
Attachment #8586612 - Flags: review?(timdream) → feedback+
Actually, the feedback might be wrong (e.g. caps on the highlight) if we trigger it earlier than we should. Let's just verify the patch with Flame 319MB and if it works we would just have to ship it.
Comment on attachment 8586612 [details] [review]
[gaia] RudyLu:keyboard/Bug1145072-keyboard_action_queue > mozilla-b2g:master

Tim, 

Yes, thanks for the advice.

Just tested my patch on Flame with 319MB RAM, and did not perceive obvious delay for the feedback, so I think this is good to go.

Set review flag again for your help.
Attachment #8586612 - Flags: review?(timdream)
Comment on attachment 8586612 [details] [review]
[gaia] RudyLu:keyboard/Bug1145072-keyboard_action_queue > mozilla-b2g:master

See comments.
Attachment #8586612 - Flags: review?(timdream) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8586612 [details] [review]
[gaia] RudyLu:keyboard/Bug1145072-keyboard_action_queue > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): regressed by Bug 985853.
[User impact] if declined: User may be confused by the output when typing really fast and tap the [Shift] key.
[Testing completed]: Yes, manually and unit tests.
[Risk to taking this patch] (and alternatives if risky): Should be low, the proposed solution is simple, while may delay the next key's UI feedback.
  Would be better if QA can double confirm.
[String changes made]: N/A
Attachment #8586612 - Flags: approval-gaia-v2.2?
Attachment #8586612 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 22

4 years ago
Posted video Verify.MP4
This bug has been verified successfully on Flame 2.2&3.0. The STR is same as Comment 0.
Reproduce rate:0/5
Attachmen:Verify.MP4
Device Flame 2.2 build(Pass)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device Flame 3.0 build(Pass)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

4 years ago
Device Nexus 5_2.2 build(Pass)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150406.035757
Firmware Date          Mon Apr  6 03:58:14 EDT 2015
Bootloader             HHZ12d

Device Nexus 5_3.0 build(Pass)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150406.194041
Firmware Date          Mon Apr  6 19:40:54 EDT 2015
Bootloader             HHZ12d
Keywords: verifyme
I would like to morph Bug 1040603 into a follow-up bug for this.
Thanks for the reminding.
Flags: needinfo?(rlu)
Duplicate of this bug: 1040603
Sorry, the follow-up should be implemented with bug 1040548.
You need to log in before you can comment on or make changes to this bug.