Intermittent browser_referrer_open_link_in_private.js,browser_referrer_open_link_in_window.js | Test timed out

RESOLVED FIXED in Firefox 40

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: franziskus)

Tracking

({intermittent-failure})

unspecified
Firefox 41
x86_64
Windows 8
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox39 wontfix, firefox40 fixed, firefox41 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

4 years ago
Posted image test screenshot
Quite the interesting screenshot this one has :)

22:31:34 INFO - 711 INFO TEST-START | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js
22:32:01 INFO - 1426743121217 Browser.Experiments.Experiments TRACE Experiments #0::enabled=true, true
22:32:01 INFO - 1426743121218 Browser.Experiments.Experiments TRACE Experiments #0::Registering instance with Addon Manager.
22:32:01 INFO - 1426743121218 Browser.Experiments.Experiments TRACE Experiments #0::Registering previous experiment add-on provider.
22:32:01 INFO - 1426743121219 Browser.Experiments.Experiments TRACE PreviousExperimentProvider #0::startup()
22:32:01 INFO - 1426743121219 Browser.Experiments.Experiments TRACE Experiments #0::_loadFromCache
22:32:01 INFO - 1426743121225 Browser.Experiments.Experiments TRACE Experiments #0::_loadTask finished ok
22:32:01 INFO - 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_run
22:32:01 INFO - 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_main iteration
22:32:01 INFO - 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_evaluateExperiments
22:32:01 INFO - 1426743121228 Browser.Experiments.Experiments TRACE Experiments #0::_main finished, scheduling next run
22:35:19 INFO - TEST-INFO | screenshot: exit status 0
22:35:19 INFO - 712 INFO checking window state
22:35:19 INFO - 713 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 714 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 715 INFO Console message: [JavaScript Error: "NS_ERROR_FACTORY_EXISTS: Component returned failure code: 0xc1f30100 (NS_ERROR_FACTORY_EXISTS) [nsIComponentRegistrar.registerFactory]" {file: "resource://shumway/ShumwayBootstrapUtils.jsm" line: 71}]
22:35:19 INFO - 716 INFO browser_referrer_open_link_in_private: policy=[undefined] rel=[undefined] http:// -> http://
22:35:19 INFO - 717 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | policy=[undefined] rel=[undefined] http:// -> http://
22:35:19 INFO - 718 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | two tabs open
22:35:19 INFO - 719 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 720 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 721 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 722 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 723 INFO browser_referrer_open_link_in_private: policy=[undefined] rel=[undefined] https:// -> http://
22:35:19 INFO - 724 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | policy=[undefined] rel=[undefined] https:// -> http://
22:35:19 INFO - 725 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | two tabs open
22:35:19 INFO - 726 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 727 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 728 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 729 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 730 INFO browser_referrer_open_link_in_private: policy=[origin] rel=[undefined] https:// -> http://
22:35:19 INFO - 731 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | policy=[origin] rel=[undefined] https:// -> http://
22:35:19 INFO - 732 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | two tabs open
22:35:19 INFO - 733 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 734 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 735 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 736 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 737 INFO browser_referrer_open_link_in_private: policy=[origin] rel=[noreferrer] https:// -> http://
22:35:19 INFO - 738 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | policy=[origin] rel=[noreferrer] https:// -> http://
22:35:19 INFO - 739 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | two tabs open
22:35:19 INFO - 740 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 741 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 742 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 743 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 744 INFO browser_referrer_open_link_in_private: policy=[origin-when-crossorigin] rel=[undefined] https:// -> https://
22:35:19 INFO - 745 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | policy=[origin-when-crossorigin] rel=[undefined] https:// -> https://
22:35:19 INFO - 746 INFO TEST-PASS | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | two tabs open
22:35:19 INFO - 747 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 748 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 749 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 750 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
22:35:19 INFO - 751 INFO Console message: 1426743121217 Browser.Experiments.Experiments TRACE Experiments #0::enabled=true, true
22:35:19 INFO - 752 INFO Console message: 1426743121218 Browser.Experiments.Experiments TRACE Experiments #0::Registering instance with Addon Manager.
22:35:19 INFO - 753 INFO Console message: 1426743121218 Browser.Experiments.Experiments TRACE Experiments #0::Registering previous experiment add-on provider.
22:35:19 INFO - 754 INFO Console message: 1426743121219 Browser.Experiments.Experiments TRACE PreviousExperimentProvider #0::startup()
22:35:19 INFO - 755 INFO Console message: 1426743121219 Browser.Experiments.Experiments TRACE Experiments #0::_loadFromCache
22:35:19 INFO - 756 INFO Console message: 1426743121225 Browser.Experiments.Experiments TRACE Experiments #0::_loadTask finished ok
22:35:19 INFO - 757 INFO Console message: 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_run
22:35:19 INFO - 758 INFO Console message: 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_main iteration
22:35:19 INFO - 759 INFO Console message: 1426743121226 Browser.Experiments.Experiments TRACE Experiments #0::_evaluateExperiments
22:35:19 INFO - 760 INFO Console message: 1426743121228 Browser.Experiments.Experiments TRACE Experiments #0::_main finished, scheduling next run
22:35:19 INFO - 761 INFO Longer timeout required, waiting longer... Remaining timeouts: 4
22:35:19 INFO - 762 INFO Console message: 1426743151865 Toolkit.GMP WARN GMPInstallManager.parseResponseXML got node name: html, expected: updates
22:35:19 INFO - 763 INFO Console message: [JavaScript Error: "1426743151865 Toolkit.GMP ERROR GMPInstallManager.simpleCheckAndInstall Could not check for addons: {"target":{},"message":"got node name: html, expected: updates"}" {file: "resource://gre/modules/Log.jsm" line: 749}]
22:35:19 INFO - 764 INFO Console message: 1426743151986 Services.HealthReport.HealthReporter WARN Saved state file does not exist.
22:35:19 INFO - 765 INFO Console message: 1426743154863 Toolkit.GMP WARN GMPInstallManager.parseResponseXML got node name: html, expected: updates
22:35:19 INFO - 766 INFO Console message: [JavaScript Error: "1426743154864 Toolkit.GMP ERROR GMPInstallManager.simpleCheckAndInstall Could not check for addons: {"target":{},"message":"got node name: html, expected: updates"}" {file: "resource://gre/modules/Log.jsm" line: 749}]
22:35:19 INFO - 767 INFO Longer timeout required, waiting longer... Remaining timeouts: 3
22:35:19 INFO - 768 INFO Longer timeout required, waiting longer... Remaining timeouts: 2
22:35:19 INFO - 769 INFO Longer timeout required, waiting longer... Remaining timeouts: 1
22:35:19 INFO - 770 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | Test timed out - expected PASS
22:35:19 INFO - 771 INFO MEMORY STAT vsize after test: 742486016
22:35:19 INFO - 772 INFO MEMORY STAT vsizeMaxContiguous after test: 8577624555520
22:35:19 INFO - 773 INFO MEMORY STAT residentFast after test: 134430720
22:35:19 INFO - 774 INFO MEMORY STAT heapAllocated after test: 64104376
22:35:19 INFO - 775 INFO TEST-OK | browser/base/content/test/referrer/browser_referrer_open_link_in_private.js | took 224868ms
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 2

4 years ago
Browser thinks it's offline?  May the wonders never cease!

Since it's unrelated to this particular test, it probably shouldn't block bug 1113431 (which I'm hoping to ship :-).

We're probably going to disable this test in e10s in bug 1144816 for a different reason, but that's totally coincidental, so they're not really duplicates.
Reporter

Comment 3

4 years ago
Yeah, I'm not entirely convinced this wasn't just an infrastructure issue. Let's see if it happens more before panicking too much :)
Comment hidden (Legacy TBPL/Treeherder Robot)
Duplicate of this bug: 1145099
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 28

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #3)
> Yeah, I'm not entirely convinced this wasn't just an infrastructure issue.
> Let's see if it happens more before panicking too much :)

It does happen more, but it's still beyond my expertise to fix, I'm afraid.  This is all windows e10s, and all the screenshots say the browser is offline.  So, either the browser comes up without network connectivity, or the test framework is not waiting for it to realize that it is connected.  Either way, this seems beyond the scope of what the test itself should be dealing with.

Shall we disable the test on windows e10s?  Other suggestions?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 33

4 years ago
@Daniel - looks like windows e10s sometimes thinks it's offline while running tests.  Is this a known issue?

Screenshot:

http://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-inbound/sha512/bc10819f3f5f34d145fa3eebead167186f7b196bdee6c2bf34550c564f36b987102b013d90e84699f278e4ae1eb6f4ef84445dc5a3e796949c33fb65be394cb8

Another possibility is that e10s occasionally freezes long enough for the offline detector to think it's offline.  It certainly did freeze for a minute or so on linux dbg, and for several minutes on mac.  But thought I'd check first if there's something windows-e10s-offline specific that you know of.
Flags: needinfo?(daniel)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This is not a known issue (to me).

Windows builds don't have 'network.manage-offline-status' set true by default so there should be nothing that sets the browser in offline mode due to the network situation. The online/offline-detection works the exact same way e10s or not.

nsIOService does however start off in offline mode and sets itself "online" when ->Init() is called which thus begs the question of there's possibly a race?
Flags: needinfo?(daniel)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

4 years ago
Summary: Intermittent browser_referrer_open_link_in_private.js | Test timed out → Intermittent browser_referrer_open_link_in_private.js,browser_referrer_open_link_in_window.js | Test timed out
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This fails a lot, should we disable the test or is anyone going to poke at it in the near future?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)