[Vista] glitches in live streams caused by lazily-open-shared-handle

RESOLVED FIXED in Firefox 37

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Assigned: mattwoodrow)

Tracking

({regression})

unspecified
mozilla39
x86_64
Windows Vista
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37+ verified, firefox38+ verified, firefox39+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8580677 [details]
Gif showing the issue

Affected OS`s:
- Windows Vista only

Affected Builds:
- Firefox 37beta7
- Latest Nightly

STR:
1. Start Firefox
2. Open a live stream (I reproduced on http://www.twitch.tv/ and http://www.douyutv.com/)

Here is a list of streams:
http://www.joindota.com/en/livestreams/ or https://new.livestream.com/watch

Expected results: Stream runs without glitches

Actual results: Lots of glitches can be seen during the stream

Notes:
1. This is a regression. I was unable to get central or inbound regression but I did manage to get a range through tinderbox beta builds:

First good - https://hg.mozilla.org/releases/mozilla-beta/rev/89cfa8ff9fc5
First bad - https://hg.mozilla.org/releases/mozilla-beta/rev/7d4016a05dd3

Pushlog: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=89cfa8ff9fc5&tochange=7d4016a05dd3
(Reporter)

Comment 1

3 years ago
Graphics
Adapter Description	AMD Radeon HD 6450
Adapter Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	1024
Device ID	0x6779
Direct2D Enabled	true
DirectWrite Enabled	true (7.0.6002.23200)
Driver Date	12-6-2013
Driver Version	13.251.0.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	21251462
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Keywords: regression
[Tracking Requested - why for this release]: Issue is Vista only, but is a regression and bad user experience on some popular websites.
status-firefox37: --- → affected
status-firefox39: --- → affected
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
tracking-firefox39: --- → ?
I think that Video/Audio is a better place to start but this may also be a gfx issue. This is not YouTube so it's not MSE.
Component: Layout → Video/Audio
So I don't lose the comment, on irc Jeff said this was probably introduced by bug 1128170 or bug 1127925.
Can you try the build here to see if it reproduces? That should narrow things down between between those bugs:
 https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-666418bb7676
Tracking until we know better.
status-firefox38: --- → ?
tracking-firefox37: ? → +
tracking-firefox38: ? → +
tracking-firefox39: ? → +
(Reporter)

Comment 7

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Can you try the build here to see if it reproduces? That should narrow
> things down between between those bugs:
>  https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/
> jmuizelaar@mozilla.com-666418bb7676

This build is also affected by glitches on my system.
Flags: needinfo?(jmuizelaar)
Based on comment 7 this is caused by bug 1127925. ni? to mattwoodrow as a heads-up. Not sure if he has cycles to look into this right now though.
Blocks: 1127925
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jmuizelaar)
Summary: [Vista] glitches in live streams → [Vista] glitches in live streams caused by lazily-open-shared-handle
Bogdan, are the streams using flash or the video tag?
Flags: needinfo?(bogdan.maris)
(Reporter)

Comment 10

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #9)
> Bogdan, are the streams using flash or the video tag?

Yes
Flags: needinfo?(bogdan.maris)
Which one?
Flags: needinfo?(bogdan.maris)
(Reporter)

Comment 12

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> Which one?

http://www.twitch.tv/, http://www.douyutv.com/ and https://new.livestream.com/watch - require Flash.
I did not encountered any live stream that did not requested Flash in order to work.
Flags: needinfo?(bogdan.maris)
(Assignee)

Comment 13

3 years ago
Created attachment 8582647 [details] [diff] [review]
Hold a ref to the right texture
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8582647 - Flags: review?(jmuizelaar)
(Assignee)

Comment 14

3 years ago
Comment on attachment 8582647 [details] [diff] [review]
Hold a ref to the right texture

Approval Request Comment
[Feature/regressing bug #]: bug 1046550 and bug 1127925
[User impact if declined]: Video flickering, seems to happen mainly on vista (but should be able to happen on 7/8 too).
[Describe test coverage new/current, TreeHerder]: Nothing yet.
[Risks and why]: Very low risk, obvious typo.
[String/UUID change made/needed]: None.

This was initially broken by bug 1046550, though it's racy and apparently very rare. Bug 1127925 increased the window where it could happen which made it show up more.
Attachment #8582647 - Flags: approval-mozilla-release?
Attachment #8582647 - Flags: approval-mozilla-beta?
Attachment #8582647 - Flags: approval-mozilla-aurora?
Comment on attachment 8582647 [details] [diff] [review]
Hold a ref to the right texture

Great simple fix for a very visible bug. Release- as we're not going to take this fix in 36. Beta+ Aurora+
Attachment #8582647 - Flags: approval-mozilla-release?
Attachment #8582647 - Flags: approval-mozilla-release-
Attachment #8582647 - Flags: approval-mozilla-beta?
Attachment #8582647 - Flags: approval-mozilla-beta+
Attachment #8582647 - Flags: approval-mozilla-aurora?
Attachment #8582647 - Flags: approval-mozilla-aurora+
Attachment #8582647 - Flags: review?(jmuizelaar) → review+
Flags: qe-verify+
(Reporter)

Comment 19

3 years ago
I retested on Firefox 37.0 RC and latest Aurora 38.0a2 under Windows Vista 64-bit and the glitches are gone.
status-firefox37: fixed → verified
status-firefox38: fixed → verified
I see this patch only landed on release, aurora, and beta but not central. Are there plans to land this on master? Thanks!
Flags: needinfo?(jmuizelaar)
(Assignee)

Comment 21

3 years ago
Yes, but inbound seems to be closed every time I try.
Flags: needinfo?(jmuizelaar)
Set checkin-needed?
https://hg.mozilla.org/mozilla-central/rev/4f8721033f5b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.