IE11 Popcorn demo has flashes of black when run.

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: streetwolf, Assigned: mchang)

Tracking

({regression})

39 Branch
x86_64
Windows 8.1
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150323103014

Steps to reproduce:

Go to http://ie.microsoft.com/testdrive/Performance/Popcorn/Default.html

Run the demos S, M, or L a few times.


Actual results:

Portions of the screen will flash black when run.  Usually on the bottom or top of the screen.


Expected results:

No black flashing.

Regression Range:

Good:  20150317193142
https://hg.mozilla.org/integration/mozilla-inbound/rev/e5a94f80f342

Bad:  20150317223048
https://hg.mozilla.org/integration/mozilla-inbound/rev/40dae5234a25
(Reporter)

Comment 1

3 years ago
Problem happens on AMD and nVidia cards.  Here's my specs:

Graphics
--------

Adapter Description: AMD Radeon HD 7900 Series
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 3072
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 100 ]
Device ID: 0x6798
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17415)
Driver Date: 3-18-2015
Driver Version: 14.502.1014.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 00000000
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7900 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Here's an Nvidia user with the same problem:

    Adapter Description   NVIDIA GeForce GTX 670
    Adapter Drivers   nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
    Adapter RAM   2048
    Device ID   0x1189
    Direct2D Enabled   true
    DirectWrite Enabled   true (6.2.9200.16571)
    Driver Date   12-13-2014
    Driver Version   9.18.13.4709
    GPU #2 Active   false
    GPU Accelerated Windows   1/1 Direct3D 11 (OMTC)
    Subsys ID   11891569
    Vendor ID   0x10de
    WebGL Renderer   Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D11 vs_5_0 ps_5_0)
    windowLayerManagerRemote   true
    AzureCanvasBackend   direct2d 1.1
    AzureContentBackend   direct2d 1.1
    AzureFallbackCanvasBackend   cairo
    AzureSkiaAccelerated   0
Keywords: regression
Hardware: x86 → x86_64
(Reporter)

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
Problem happens under e10s and non-e10s.
Did you produce this regression window with mozregression? It would be nice to have a tighter range.
Flags: needinfo?(garyshap)
There are a bunch of build inbetween those two revisions. Can you try some of them (these are 32bit builds, I presume it reproduces there too):

http://inbound-archive.pub.build.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/

	1426644398/			 
[DIR]	1426645958/			 
[DIR]	1426646200/			 
[DIR]	1426646498/			 
[DIR]	1426647522/			 
[DIR]	1426647578/			 
[DIR]	1426649930/			 
[DIR]	1426649979/			 
[DIR]	1426650458/			 
[DIR]	1426650762/			 
[DIR]	1426651239/			 
[DIR]	1426651660/
(Reporter)

Comment 6

3 years ago
Here's the culprit, makes sense.

  https://hg.mozilla.org/integration/mozilla-inbound/rev/d3380179efc1


Setting 'gfx.vsync.hw-vsync.enabled' to False stops the flashing.
Flags: needinfo?(garyshap)
(Reporter)

Comment 7

3 years ago
Did some more testing with the vsync prefs.  Seems that setting 'gfx.vsync.compositor' to false also stops the flashing.  As long as one of the prefs I mentioned is set to false there is no flashing.
(Reporter)

Comment 8

3 years ago
Don't know if it's related but Popcorn is much slower now no matter how I set the vsync prefs.
(Reporter)

Comment 9

3 years ago
(In reply to Gary [:streetwolf] from comment #8)
> Don't know if it's related but Popcorn is much slower now no matter how I
> set the vsync prefs.

Under e10s it is definitely very fast. Non-e10s it seems to have gotten slower.
(Assignee)

Updated

3 years ago
See Also: → bug 1145327
(Assignee)

Updated

3 years ago
See Also: → bug 1147025
(Assignee)

Updated

3 years ago
See Also: bug 1145327
(Assignee)

Comment 10

3 years ago
I can reproduce on Windows 7 and 8.

STR:
1) Go to http://ie.microsoft.com/testdrive/Performance/popcorn/
2) Push small on the bottom
3) Keep pushing play, see small flashes of black
(Reporter)

Comment 11

3 years ago
Can someone please change this to confirmed?
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 12

3 years ago
I'm still kind of poking in the dark here but I have some notes:

1) Using software vsync instead of dwm composition to schedule composites can still cause the flashing to occur. It seems unrelated to using DwmFlush as a way to listen to vsync.
2) Forcing us to wait for vsync (https://dxr.mozilla.org/mozilla-central/source/gfx/layers/d3d11/CompositorD3D11.cpp?from=CompositorD3D11.cpp&case=true#1154) by changing the Present parameters doesn't change anything.
3) By disabling Dwm Composition as a Windows setting, minimizing and maximizing the window on this page specifically causes us to consistently flash the whole page black. Chrome and IE do not flash black when being minimized / maximized on this page. Firefox not does flash black on simpler pages such as reddit.
4) The places we flash black are the layers that are being invalidated during paint invalidation during the animation.
5) With the patches from bug 1145327, which ensure timestamps are always in the future, does not affect this bug but has caused weird animation problems before.

I'm wondering if we're invalidating layers black then dwm composites so we see the flash of black rather than this is a fundamental problem with the silk approach on windows of using Dwm composition.
(Assignee)

Updated

3 years ago
See Also: → bug 1145295
(Assignee)

Comment 13

3 years ago
I verified that with the patch in bug 1145585, which showed the same symptoms of flashing black, this problem is fixed. Will leave open until bug 1145585 lands to get verification that this is fixed.
Depends on: 1145585
See Also: bug 1147025, bug 1145295
(Assignee)

Comment 14

3 years ago
I cannot reproduce on Windows 7 or 8 with today's nightly (3-27-2015). Gary, can you please test again and verify that this issue is resolved for you? Thanks!
Flags: needinfo?(garyshap)
(Reporter)

Comment 15

3 years ago
I can't reproduce it either.  Any idea what might have fixed it?
Flags: needinfo?(garyshap)
(Assignee)

Comment 16

3 years ago
bug 1145585 fixed it from comment 13. Resolving as WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.