Separate out persistent log setting into individual settings for the netmonitor and console

RESOLVED DUPLICATE of bug 1307881

Status

P3
normal
RESOLVED DUPLICATE of bug 1307881
4 years ago
4 months ago

People

(Reporter: canuckistani, Unassigned)

Tracking

(Blocks: 3 bugs, {dev-doc-needed})

36 Branch
dev-doc-needed
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-papercuts][polish-backlog])

Attachments

(1 attachment)

Created attachment 8580764 [details]
Hacker_News_and_Hacker_News.png

Use case: I want to monitor network traffic from a site only for the current page load and subsequent xhr requests, BUT I want to see all logs in the console at the same time via the split console, across multiple page loads so I can compare logged objects etc.

Firebug has the persist setting per-tool and in the tool itself, whereas our setting is 'global' to both tools and buried in the settings panel. See this uservoice feedback for an example of users not knowing the setting exists:

https://ffdevtools.uservoice.com/forums/246087-firefox-developer-tools-ideas/suggestions/7254831-persist-network-tab-information-across-pages
Whiteboard: [devedition-40]
Whiteboard: [devedition-40] → [console-papercuts][devedition-40]
Setting devedition-40 bugs to p3, filter on FB20EAC4-3FC3-48D9-B15F-0587C3987C25
Priority: -- → P3
Whiteboard: [console-papercuts][devedition-40] → [console-papercuts][polish-backlog]
Duplicate of this bug: 1312168
Keywords: dev-doc-needed
OS: Mac OS X → All
Hardware: x86 → All
See Also: → bug 1336045
See Also: → bug 1307881
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1307881

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.