commonDialog is slow as molasses

RESOLVED FIXED in mozilla0.9.9

Status

SeaMonkey
UI Design
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Joe Hewitt (gone), Assigned: Joe Hewitt (gone))

Tracking

({perf})

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

16 years ago
Ever try calling alert() in rapid succession, and notice that the dialog takes
forever to appear? I have.

commonDialog.xul needs to get spanked.
(Assignee)

Comment 1

16 years ago
Working on this... just by changing collapsed="true" to hidden="true" on the
optional container boxes, I save about 60% of window open time.  Hyatt reminded
me that doing this is tricky because that will cause the textbox/checkbox
bindings to load async when they are shown, so I have to be sure to unset hidden
from an inline function call instead of from onload.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 2

16 years ago
Created attachment 61248 [details] [diff] [review]
patch

This patch cleans up the commonDialog xul and js, changes collapsed to hidden
on the textbox containers, converts to use the dialog tag, and updates the
dialog tag to support extra buttons.
(Assignee)

Comment 3

16 years ago
Created attachment 61251 [details] [diff] [review]
improved patch
Attachment #61248 - Attachment is obsolete: true
Keywords: perf
QA Contact: sairuh → jrgm
(Assignee)

Updated

16 years ago
Attachment #61251 - Attachment is obsolete: true
(Assignee)

Comment 4

16 years ago
Created attachment 63887 [details] [diff] [review]
patch 3.0

Comment 5

16 years ago
r=/sr=jag with the bug pointer.
Comment on attachment 63887 [details] [diff] [review]
patch 3.0

r=bryner
Attachment #63887 - Flags: review+
a=blizzard on behalf of drivers for the cropping fixes
Keywords: mozilla0.9.8+
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 8

16 years ago
looks like this is checked in. can it be resolved?
Asa: only dialog.xml was checked in, the rest of the patch hasn't landed yet.
Removing the 0.9.8+ since my memory of the discussion was that we only wanted
part of the patch for 0.9.8 (and thought the rest could wait), and it looks like
part of the patch was checked in (I'm assuming the part we decided).  If I got
confused here and there's still something that needs to go in for 0.9.8, please
get it in sooner rather than later.
Keywords: mozilla0.9.8+
(Assignee)

Comment 11

16 years ago
almost forgot about this - landed on trunk now
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
This checkin caused the regression in bug 123216.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.