Crash launching Address Book 3rd time in 1 Messenger session

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
critical
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: esther, Assigned: hangas)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using 19990909 on win32, you will crash if you launch Address Book 3x in 1
Messenger session.  May be related to bug 11399, but this crashes after the 2rd
launch that crashes after the 1st launch and I can't check 11399 has changed to
this scenario yet.  Haven't check Mac yet, I will change Summary if appropriate.

1. Launch Messenger
2. Select Address Book from Tasks menu
3. Close Address Book
4. Repeat steps 2 & 3 two more times, crash on 3rd launch

Results: This is where it crashes now.
Expected: it to open

Call Stack
nsTableFrame::DidComputeHorizontalCollapsingBorders
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 984]
nsTableFrame::ResizeReflowPass2
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2654]
nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2317]
nsTreeFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeFrame.cpp, line 294]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
nsTableOuterFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
1044]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
224]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2744]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2137]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1929]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1239]
nsBoxFrame::FlowChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 859]
nsBoxFrame::GetChildBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 227]
nsBoxFrame::GetBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1231]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 322]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
RootFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 330]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 513]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 807]
XULDocumentImpl::StartLayout
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 4077]
XULDocumentImpl::EndLoad
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1897]
XULContentSinkImpl::DidBuildModel
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line 549]
CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 308]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 530]
nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 893]
nsParser::EnableParser
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 620]
CSSLoaderImpl::Cleanup
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 646]
CSSLoaderImpl::ParseSheet
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 751]
0x09a4a630
Registers:
EAX:
00000000
EBX:
00000000
ECX:
000001e0
EDX:
0063cbd0
ESI:
60b0c44a
EDI:
09a83fac
ESP:
0063cbc0
EBP:
0063cbf0
EIP:
604e2c90
cf pf af zf sf of IF df nt RF vm   IOPL: 0
CS:
0137
DS:
013f
SS:
013f
ES:
013f
FS:
4637
GS:
0000

Comment 1

19 years ago
this looks like a dup of 11441.  If you agree, please mark it as such and update
that bug.
(Assignee)

Updated

19 years ago
Assignee: chuang → hangas
Depends on: 11441
Target Milestone: M10
(Assignee)

Comment 2

19 years ago
I am taking this bug back since it looks like a UI layer problem.  We will watch

bug 11441 to see if that fix will fix this.

Comment 3

19 years ago
Well,  I have a crash with a different call stack, I think I got that one and
will check in the fix for it today. Just for referencing my call stack will
related to nsServiceManager.  The step is same with this one, but I crash on the
4 th time.  I was unable to reproduce this bug so far.  My tree has my changes
which is not in the build yet,  I'll check it in and let's keep watching it.
(Reporter)

Comment 4

19 years ago
Just tested Mac, doesn't crash but has other problems on 3rd launch see bug
11403

Comment 5

19 years ago
Can this be fixed for M9?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
I have no control over this one.  Will just try to see if bug 11441 gets fixed
today.

Comment 7

19 years ago
I get what Candice gets.  I don't get the call stack esther entered but instead
one that shows a crash getting a service.  It happes on the 4th or 5th time I do
this.  Esther said she will try to reproduce this.  For the moment I think this
may not be related to 11441.
(Assignee)

Comment 8

19 years ago
Interesting, when I first heard about this bug it seemed like the crash I was
seeing that had the address book backend in the stack trace.  But when Esther put
this stack trace into the bug I thought it was something different.  Candice
should we give this back to you and remove the depends on 11441?
(Reporter)

Comment 9

19 years ago
Sorry for the misinformation... When I checked Talkback reports using my email
name incident 12207923 was reported as my most recent incident, so I put that
one in this bug. Today it still showed as my most recent, however I clicked on
the link within this incident and found what was really my last reported
incident. 12211159 is really my last incident report which is the one for this
bug.  Hopefully this matches what Candice and Scott are looking for.  In any
case, I can't reproduce this today.  I had removed my abook.mab file many times
yesterday researching another bug, so I'm not sure if that file was the cause of
this problem.

Here is the real Call Stack for this bug
Call Stack:    (Signature = PL_HashTableLookup 701b944e)
PL_HashTableLookup
[plhash.c, line 344]
ServiceImpl::GetResource
[d:\builds\seamonkey\mozilla\rdf\base\src\nsRDFService.cpp, line 515]
nsRDFContentUtils::GetElementResource
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFContentUtils.cpp, line 217]
RDFXULBuilderImpl::CreateContents
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFXULBuilder.cpp, line 678]
XULDocumentImpl::CreateContents
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2586]
RDFElementImpl::EnsureContentsGenerated
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2636]
RDFElementImpl::ChildCount
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 1532]
RDFGenericBuilderImpl::FindTemplate
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFGenericBuilder.cpp, line 1613]
RDFGenericBuilderImpl::CreateWidgetItem
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFGenericBuilder.cpp, line 2013]
RDFGenericBuilderImpl::CreateContainerContents
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFGenericBuilder.cpp, line 2320]
RDFGenericBuilderImpl::CreateContents
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFGenericBuilder.cpp, line 491]
XULDocumentImpl::CreateContents
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2586]
RDFElementImpl::EnsureContentsGenerated
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2636]
RDFElementImpl::ChildCount
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 1532]
nsTreeRowGroupFrame::GetFirstFrameForReflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeRowGroupFrame.cpp, line
810]
nsTableRowGroupFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 406]
nsTableRowGroupFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 1052]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
nsTableRowGroupFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 473]
nsTableRowGroupFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 1052]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
nsTableFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 3574]
nsTableFrame::ResizeReflowPass2
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2626]
nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2317]
nsTreeFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeFrame.cpp, line 294]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
nsTableOuterFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
1044]
nsBoxFrame::FlowChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 859]
nsBoxFrame::GetChildBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 227]
nsBoxFrame::GetBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1231]
nsBoxFrame::GetChildBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 180]
nsBoxFrame::GetBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1231]
nsBoxFrame::GetChildBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 180]
nsBoxFrame::GetBoxInfo
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1231]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 322]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
RootFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 330]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 513]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 807]
XULDocumentImpl::StartLayout
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 4077]
XULDocumentImpl::EndLoad
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1897]
XULContentSinkImpl::DidBuildModel
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line 549]
CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 308]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 530]
nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 893]
nsParser::EnableParser\
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 620]
XULContentSinkImpl::UpdateOverlayCounters
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line 1980]
XULContentSinkImpl::CloseContainer
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line 707]
CWellFormedDTD::HandleToken
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 536]
CWellFormedDTD::BuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 254]
nsParser::BuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 943]
nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 888]
nsParser::EnableParser
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 620]
XULContentSinkImpl::DoneLoadingScript
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line 1679]
nsUnicharStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\util\src\nsNetStreamLoader.cpp, line 162]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
274]
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
150]
PL_HandleEvent
[plevent.c, line 510]
PL_ProcessPendingEvents
[plevent.c, line 471]
_md_EventReceiverProc
[plevent.c, line 936]
KERNEL32.DLL + 0x3663 (0xbff73663)
KERNEL32.DLL + 0x228e0 (0xbff928e0)
0x00638c00
Registers:
EAX:
007cb610
EBX:
80000000
ECX:
605ace2c
EDX:
816d230c
ESI:
0063e044
EDI:
00000000
ESP:
0063df68
EBP:
0063e024
EIP:
60a420eb
cf pf af zf sf of IF df nt RF vm   IOPL: 0
CS:
0137
DS:
013f
SS:
013f
ES:
013f
FS:
523f
GS:
0000
(Reporter)

Comment 10

19 years ago
Using 1999081009 on win95, I can't reproduce this.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 11

19 years ago
The bug this was depending on has been closed.  I am marking works for me since

Esther is no longer able to reproduce it and the bug we thought caused it has

been closed.

Updated

19 years ago
QA Contact: lchiang → esther
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

19 years ago
verified as worksforme
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.