Open Bug 1146948 Opened 8 years ago Updated 2 months ago

about:performance should let me pause/unload a tab

Categories

(Toolkit :: Performance Monitoring, enhancement)

x86
macOS
enhancement

Tracking

()

People

(Reporter: Yoric, Unassigned)

References

Details

If a tab consumes resources, it would be useful to have a button to put it on pause, i.e. revert it to a load-on-demand state, as handled by Session Restore.
Depends on: 1128502
No longer depends on: 1156788
Severity: normal → enhancement
Component: General → Performance Monitoring
Product: Firefox → Toolkit
Bug 1128502 (marked as dependency) was resolved duplicate of bug 1322485 which in turn was resolved fixed in Firefox 58.

See also Bug 1498193 (same idea, but different proposed API / implementation).

As bug 1498193 is in the dependency tree for bug 1478832 (new-about-performance), so maybe:

  • this bug 1146948 should be added to the tree
  • with greater distinction between the titles of 1146948 and 1498193
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.