If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Expose fetch Response.body and Request.body as streams

RESOLVED DUPLICATE of bug 1128959

Status

()

Core
DOM
P2
normal
RESOLVED DUPLICATE of bug 1128959
3 years ago
a month ago

People

(Reporter: bkelly, Assigned: valentin)

Tracking

(Depends on: 2 bugs, Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Facebook][qf-])

(Reporter)

Description

3 years ago
We should investigate and consider implementing Request.body and Response.body attributes as streams.  Proposal is here:

  https://github.com/yutakahirano/fetch-with-streams

Blink intends to ship an implementation:

  https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/35_QSL1ABTY
(Reporter)

Updated

2 years ago
Depends on: 1204254
(Reporter)

Updated

a year ago
Blocks: 1283191
Tracking under 'platform-rel-Facebook'. This issue is blocking Facebook from rolling out service worker to users and providing more feedback on Firefox's implementation.
Whiteboard: platform-rel-Facebook
platform-rel: --- → +
Whiteboard: platform-rel-Facebook → [platform-rel-Facebook]
(Assignee)

Updated

6 months ago
Assignee: nobody → valentin.gosu
Whiteboard: [platform-rel-Facebook] → [platform-rel-Facebook][necko-active]
Whiteboard: [platform-rel-Facebook][necko-active] → [platform-rel-Facebook]
I've been told once facebook rolls this out Chrome will receive a considerable startup perf boost relative to firefox if we don't support this. We should see if we need this to be competitive.
Flags: needinfo?(dchinniah)
Whiteboard: [platform-rel-Facebook] → [platform-rel-Facebook][qf]
adding dev-doc-needed, just in case we need to update docs as a result.
Keywords: dev-doc-needed
(In reply to Bas Schouten (:bas.schouten) from comment #2)
> I've been told once facebook rolls this out Chrome will receive a
> considerable startup perf boost relative to firefox if we don't support
> this. We should see if we need this to be competitive.

Adding :overholt for his direction...
Flags: needinfo?(dchinniah) → needinfo?(overholt)
Thanks for bringing this up, Bas. We're aware of some of the work Facebook has been doing here and have requested some more information (they have already been great about sharing their results). If that comes back showing that this is super super important, we'll see if we can shuffle this bug's priority. Barring that, this is still on our "next most important thing" list.
Flags: needinfo?(overholt)
Priority: -- → P2
Whiteboard: [platform-rel-Facebook][qf] → [platform-rel-Facebook][qf-]
I'm implementing this feature in bug 1128959.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1128959
The important thing is the design of this api. It might permits not only to use a byte reader but also a way for transforming a stream in another stream. For example you receive a particular text stream and it convert it another stream after a manupulation. 
In addition it is necessary to create a custom reader/writer also in javascript not only in native code. I could create a algorithm generating a stream(for example a sound,...). This api in future might replace a lot of not mature api for reading/writing video/audio streams.
Keywords: dev-doc-needed
(Reporter)

Updated

a month ago
Depends on: 1390638
You need to log in before you can comment on or make changes to this bug.