Closed Bug 1147381 Opened 5 years ago Closed 5 years ago

Share Button crashes on iPad

Categories

(Firefox for iOS :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: st3fan, Assigned: st3fan)

References

Details

Attachments

(1 file)

reason: 'UIPopoverPresentationController (<_UIAlertControllerActionSheetRegularPresentationController: 0x78e1dca0>) should have a non-nil sourceView or barButtonItem set before the presentation occurs.'

This is because you can't present the UIActivityViewController modally on the iPad. Instead we have to configure a UIPopoverPresentationController so that it appears in a popover instead.
This fixes a crash on the iPad that happens when we try to present the UIActivityController.

Because we need to know the source view/frame of the button pressed, i have also added a reference to the button in the BrowserToolbarDelegate functions.
Attachment #8583066 - Flags: review?(bnicholson)
Attachment #8583066 - Flags: review?(bnicholson) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1144471
Duplicate of this bug: 1151038
tracking-fennec: ? → +
You need to log in before you can comment on or make changes to this bug.