bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Flame: intermittent UI Freeze in settings -> sounds and ringtones

RESOLVED FIXED

Status

Firefox OS
Gaia::Music
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: njpark, Unassigned)

Tracking

({crash})

unspecified
All
Android
crash
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [3.0-Daily-Testing], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1139157 +++

The fix for bug 1139157 (https://bugzilla.mozilla.org/show_bug.cgi?id=1139157#c14) has an unintended side effect in 2.2 where the UI does not respond to touch except scrolling action. (See https://bugzilla.mozilla.org/show_bug.cgi?id=1139157#c18_ 

This bug is created as a follow-up bug for Bug 1139157.
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Flags: needinfo?(npark)
(Reporter)

Comment 2

3 years ago
(In reply to JW Wang [:jwwang] from comment #1)
> https://www.youtube.com/watch?v=nAgnyAI3CeA&feature=youtu.be
> 
> What is the black/white screen at 18s?

Sorry, that is the video copied from the previous bug.  The black/white screen is the crash notification, which does not occur anymore after the patch.  In the new bug, At that point when the black/white screen occurs, the UI can be scrolled, but none of the other UIs were responding other than the home button.  I'll remove the video link from above.
Flags: needinfo?(npark)
The fix in bug 1139157 is just a null-check which should have nothing to do with UI hang. I think the UI bug is disclosed because the crash is fixed. We should change the bug title to a less confusing one and have UI people to look at this bug.
Flags: needinfo?(npark)
Btw, can you also test if UI freeze also happens to flame3.0?
(Reporter)

Comment 5

3 years ago
 (In reply to JW Wang [:jwwang] from comment #4)
> Btw, can you also test if UI freeze also happens to flame3.0?

Will do, since the patch for Bug 1147386 isn't in yet, perhaps I should make it clear in this bug and change it later when it's in master.
Flags: needinfo?(npark)
Summary: Fix in crash in mozilla::MediaDecoderStateMachine::SendStreamData() causes UI Freeze → Flame: intermittent UI Freeze in settings -> sounds and ringtones
(Reporter)

Updated

3 years ago
Flags: needinfo?(npark)
(Reporter)

Comment 6

3 years ago
Actually. with the patch applied to the gecko, I saw crash happening while following the steps in https://bugzilla.mozilla.org/show_bug.cgi?id=1139157#c12.

Gecko commit used:
6e1a7d81f6d6481f5b9e31605167d483f05e12b8 in master branch
Crash stat:
https://crash-stats.mozilla.org/report/index/beaf4c2d-daad-4c88-a81c-c13102150327

But I did not see the UI freeze in 3.0.  This crash could be from a different bug, I'll try to get the symbols to get the stack messages.
Flags: needinfo?(npark)
(Reporter)

Comment 7

3 years ago
Created attachment 8584619 [details]
dumpanalysis.log

This is the analysis of the crash dump, when applied to 3.0 master branch gecko.

Also note that for some reason the patch tool failed even though the code seemed mergeable, so I pasted the 3 line if statement manually.
Flags: needinfo?(jwwang)
(Reporter)

Comment 8

3 years ago
Also it should be noted that repro rate for the crash in Comment 6 is very low, I was able to repro it 1 out of 10 times.
(In reply to No-Jun Park [:njpark] from comment #7)
> Created attachment 8584619 [details]
> dumpanalysis.log
> 
> This is the analysis of the crash dump, when applied to 3.0 master branch
> gecko.
> 
> Also note that for some reason the patch tool failed even though the code
> seemed mergeable, so I pasted the 3 line if statement manually.

Some questions:
1. Is the crash reproducible on 2.2 after applying the patch in bug 1139157?
2. The patch of bug 1139157 shouldn't apply to 3.0. Can you repro it on 3.0 without applying the patch?

The stack trace doesn't look like that of bug 1139157. Please file a new bug for it.
Flags: needinfo?(jwwang)
(Reporter)

Comment 10

3 years ago
> 
> The stack trace doesn't look like that of bug 1139157. Please file a new bug
> for it.

Oh, I thought in Comment 4 you asked me to apply the patch to 3.0 and try it. If you actually meant that I should have tested the 3.0 vanilla for UI freeze, that was already done, and no issues were found there.

So for your questions,

1. The crash is not reproducible on 2.2 after applying the patch in bug 1139157. Only the UI freeze was seen.
2. No. 3.0 without the patch does not show any issues.
(Reporter)

Comment 11

3 years ago
Update: 

I just tested the *debug* build of the master (3.0) today, and I was able to see the crash. Until last week, the problem was not reproducible in 3.0, perhaps because I was only using the eng build.
It caused the following assertion failure:
F/PRLog   ( 7450): Assertion failure: lock->locked && pthread_equal(lock->owner, pthread_self()), at ../../../../../gecko/nsprpub/pr/src/pthreads/ptsynch.c:226

crash log:
https://crash-stats.mozilla.org/report/index/65fd17fa-425b-4ea6-8440-a33de2150330

Version info:
Build ID               20150330023007
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/ee5a8ba64485
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.055351
Firmware Date          Mon Mar 30 05:54:00 EDT 2015
Bootloader             L1TC000118D0
(In reply to No-Jun Park [:njpark] from comment #11)
> crash log:
> https://crash-stats.mozilla.org/report/index/65fd17fa-425b-4ea6-8440-
> a33de2150330

I see audioTrack_callBack_pullFromBuffQueue in the stack trace. It looks the same as that of bug 945335.
(In reply to No-Jun Park [:njpark] from comment #11)
> Update: 
> 
> I just tested the *debug* build of the master (3.0) today, and I was able to
> see the crash. Until last week, the problem was not reproducible in 3.0,
> perhaps because I was only using the eng build.
> It caused the following assertion failure:
> F/PRLog   ( 7450): Assertion failure: lock->locked &&
> pthread_equal(lock->owner, pthread_self()), at
> ../../../../../gecko/nsprpub/pr/src/pthreads/ptsynch.c:226
> 
> crash log:
> https://crash-stats.mozilla.org/report/index/65fd17fa-425b-4ea6-8440-
> a33de2150330
> 

I do not think it is dup of bug 945335. It calls __android_log_assert() in the stack and crash reason is SIGABRT.


bug 945335 does not have __android_log_assert() in crash stack and crash reason is SIGSEGV. 

https://crash-stats.mozilla.com/report/list?product=B2G&signature=audioTrack_callBack_pullFromBuffQueue#tab-reports

https://crash-stats.mozilla.com/report/list?product=B2G&signature=audioTrack_callBack_pullFromBuffQueue#tab-reports
(In reply to No-Jun Park [:njpark] from comment #11)
> Update: 
> 
> I just tested the *debug* build of the master (3.0) today, and I was able to
> see the crash. Until last week, the problem was not reproducible in 3.0,
> perhaps because I was only using the eng build.
> It caused the following assertion failure:
> F/PRLog   ( 7450): Assertion failure: lock->locked &&
> pthread_equal(lock->owner, pthread_self()), at
> ../../../../../gecko/nsprpub/pr/src/pthreads/ptsynch.c:226

From the log PR_AssertCurrentThreadOwnsLock() check seems to be failed.

https://dxr.mozilla.org/mozilla-central/source/nsprpub/pr/src/pthreads/ptsynch.c#226
(Reporter)

Comment 15

3 years ago
Raised bug 1150128 to track Cooment 11
(Reporter)

Comment 16

3 years ago
So since this landed in 2.2, can Qanalysts double check whether the latest version of 2.2 shows UI Freeze when following the STR for  bug 1139157?    If it still happens, I think the component should be changed to Settings app, rather than the Music app because the freeze happens within Settings.
Keywords: qawanted
I cannot reproduce either the crash nor the UI freeze on latest 2.2 nightly production build. I tried to follow the video posted at bug 1139157 comment 13 and I failed to see any crash or UI freeze.

Leaving qawanted for someone else to attempt.

Device: Flame 2.2 (KK, full flashed, 319MB mem)
BuildID: 20150410002502
Gaia: df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
Gecko: 091b1cc1240b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
I can consistently get the phone to crash and reset following kevin's steps from bug1139157 comment 12 but it does not generate a crash report so I'm unsure if this is actually the same issue or not.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150410002502
Gaia: df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
Gecko: 091b1cc1240b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(npark)
Flags: needinfo?(ktucker)
(Reporter)

Comment 19

3 years ago
(In reply to Jayme Mercado [:JMercado] from comment #18)
> I can consistently get the phone to crash and reset following kevin's steps
> from bug1139157 comment 12 but it does not generate a crash report so I'm
> unsure if this is actually the same issue or not.
> 
> Environmental Variables:
> Device: Flame 2.2
> BuildID: 20150410002502
> Gaia: df0e04acad7c8c993f6ffe07b0ccb0ec20ee50bb
> Gecko: 091b1cc1240b
> Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
> Version: 37.0 (2.2) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Actually, could you try to reproduce the crash in 2.2 one more time, collect the logcat and make a comment in 1139157? (and ping JW Wang?)  If it's a different issue, then we can create a new bug on it.
Flags: needinfo?(npark) → needinfo?(jmercado)
Bug 1139157 comment 27 covers the request from comment 19.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado) → needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 21

3 years ago
Since the freeze itself is not happening, and the crash issue is being discussed in Bug 1139157 and bu 1150128, it's better to close this bug for clarity.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.