Closed Bug 1147448 Opened 7 years ago Closed 7 years ago

Large OOM in mp4_demuxer::Box::Box

Categories

(Core :: Audio/Video, defect)

37 Branch
x86
Windows 8.1
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1149278
Tracking Status
firefox37 --- affected
firefox38 - affected

People

(Reporter: vtamas, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ee388e06-95ce-4f88-9c3d-f16272150325 .


- Ran into this on Windows 8.1 32-bit, using Firefox 37 (build ID: 20150324194038).
- I don't have proper STR, but it happened during a 4k video testing on https://www.youtube.com/. 
- Tried several other times to reproduce it, without any luck.
- The crash rates increased in Firefox 37 Beta 7 and are affected only 32bit versions of Windows
This seems to be coming from mp4_demuxer::Box::Box and I do not think we should expect a 12MB allocation to always succeed, so this should probably use a fallible allocation instead of an infallible one.
Component: General → Video/Audio
Depends on: 1149288
Keywords: crash
Summary: [@ OOM | large | mozalloc_abort(char const* const) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::EnsureCapacity(unsigned int, unsigned int) | nsTArray_base<nsTArrayInfallibleAllo → Large OOM in mp4_demuxer::Box::Box
[Tracking Requested - why for this release]:

Note that this signature is the #2 of crashes on YouTube in the 37.0 RC/release build so far.

For that, I think we'll want to track at least for 38.
Impacts a major website, tracking!
Anthony, this is a critical issue. Is it possible to have someone to work on it? Thanks
Flags: needinfo?(ajones)
Does bug 1149278 fix the issue?
Flags: needinfo?(ajones)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149278
Sylvestre - can we untrack this?
Flags: needinfo?(sledru)
indeed, thanks
Flags: needinfo?(sledru)
You need to log in before you can comment on or make changes to this bug.