Primetime MSE content playback will crash when playback ends: [@ OOM | large | mozalloc_abort(char const* const) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::EnsureCapacity(unsi

RESOLVED DUPLICATE of bug 1149278

Status

()

Core
Audio/Video
P1
normal
RESOLVED DUPLICATE of bug 1149278
3 years ago
3 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 2 bugs, {crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
John Xu from Adobe reports:

I attached the debugger to plugin-container.exe and found out the crash actually happens inside the firefox.exe instead of plugin-container (No except in plugin-container at all). 

You can reproduce the bug by playing content at http://drmtest2.adobe.com/HTML5AAXSPlayer/2/mse-access/index.html  

3/26 nightly works fine.

cpearce reports:

Can repro here. Looks like an OOM crash in the demuxer;

https://crash-stats.mozilla.com/report/index/0da48627-387b-4f16-b54c-749112150330
(Reporter)

Updated

3 years ago
Priority: -- → P1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149278

Updated

3 years ago
Crash Signature: [@ OOM | large | mozalloc_abort(char const* const) | mozalloc_handle_oom(unsigned int) | moz_xmalloc | nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::EnsureCapacity(unsigned int, unsigned int) | nsTArray_base<nsTArrayInfalli&hellip;
You need to log in before you can comment on or make changes to this bug.