Green bar with YouTube on Mac

VERIFIED FIXED in Firefox 38

Status

()

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ajones, Assigned: jya)

Tracking

(Blocks 1 bug, {regression})

unspecified
mozilla40
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 fixed, firefox39 fixed, firefox40 fixed)

Details

Attachments

(3 attachments)

Replaying the same video several times I got a green bar on the right hand side of the screen.
Asynchronous Pan/Zoom       none
Device ID                   0x6741
GPU Accelerated Windows     1/1 OpenGL (OMTC)
Vendor ID                   0x1002
WebGL Renderer              ATI Technologies Inc. -- AMD Radeon HD 6630M OpenGL Engine
windowLayerManagerRemote    true
AzureCanvasBackend          quartz
AzureContentBackend         quartz
AzureFallbackCanvasBackend  none
AzureSkiaAccelerated        0
Assignee

Comment 2

4 years ago
Vevo are MSE now? There weren't last time I played one of them. 

What OS?
(In reply to Jean-Yves Avenard [:jya] from comment #2)
> Vevo are MSE now? There weren't last time I played one of them. 
> 
> What OS?

YouTube (see URL). Mac OSX 10.7. Setting the video to 480 lines gives a resolution of 859x480 so we may need to crop the RHS of the output image or something. I can also reproduce it on my MacBook Pro with a GeForce GT 330M.
Assignee

Comment 4

4 years ago
round to lowest nearest integer
Attachment #8583626 - Flags: review?(ajones)
Assignee

Updated

4 years ago
Assignee: nobody → jyavenard
Status: NEW → ASSIGNED
Attachment #8583626 - Flags: review?(ajones) → review+
Can we land this now that merge day has passed?
Flags: needinfo?(jyavenard)
Assignee

Comment 6

4 years ago
Anthony said that didn't fix the problem for him.. I have received the mac mini which exhibited the problem.. just need to find the time to investigate now
Flags: needinfo?(jyavenard)
Assignee

Updated

4 years ago
Duplicate of this bug: 1151291
Assignee

Comment 8

4 years ago
The default chrome format is 4:2:0, not monochrome \!
Attachment #8589003 - Flags: review?(ajones)
Attachment #8589003 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/d540c29d5c2f
https://hg.mozilla.org/mozilla-central/rev/801b4019fb00
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
I verified that this fixed the video problem I reported in duplicate bug 1151291.

Jean-Yves: should we uplift this fix to Aurora 39 or Beta 38? AFAIK, we plan to ship MSE for YouTube on OS X in Firefox 38.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jyavenard)
Assignee

Comment 12

4 years ago
Comment on attachment 8589003 [details] [diff] [review]
Part2. Properly calculate cropping value

Approval Request Comment
[Feature/regressing bug #]: 1147744
[User impact if declined]: Image displayed may shows invalid pixels
[Describe test coverage new/current, TreeHerder]: Minimal testing, ensuring that it didn't introduce obvious regressions and testing against values returned by WMF.
[Risks and why]: Low, this is more closely implementing the H264 specs and fixes a invalid default value
[String/UUID change made/needed]: None
Flags: needinfo?(jyavenard)
Attachment #8589003 - Flags: approval-mozilla-beta?
Attachment #8589003 - Flags: approval-mozilla-aurora?
Comment on attachment 8589003 [details] [diff] [review]
Part2. Properly calculate cropping value

Approving for uplift to aurora; low-risk regression fix.
Attachment #8589003 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assignee

Comment 15

4 years ago
This code path wasn't activated on Mac (and still isn't by default) so not really a regression
Comment on attachment 8589003 [details] [diff] [review]
Part2. Properly calculate cropping value

Taking it in case we decide to do something with MSE under Mac.
Should be in 38 beta 4.
Attachment #8589003 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.