Closed Bug 1147753 Opened 5 years ago Closed 5 years ago

[Nexus 5] screen flashing and get stuck sometimes

Categories

(Core :: General, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla39
blocking-b2g 2.2+
Tracking Status
firefox37 --- wontfix
firefox38 --- wontfix
firefox39 --- fixed
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: hcheng, Assigned: jerry)

References

()

Details

(Keywords: qablocker, Whiteboard: [v2.2-nexus-5-l])

Attachments

(2 files)

Attached file flashing.log
* Description:
When I used below FxOS 2.2 pvt build, usually I got several screen problems listed below:
a. screen flashing (at Lockscreen, at Homescreen, at some apps)
b. blank screen only has background at Homescreen
c. Homescreen only has app names but no app icons
d. got stuck at Card View, only software
e. slow response when unlock at Lockscreen 

It is hard to find a STR. It seems easily occur when using Card View or Camera recording.

* Env: (before this 2.2 pvt build, this issue does not exist)
Build ID               20150325002503
Gaia Revision          aeee2a54caa8ffb875b96264b61d742b70689f22
Gaia Date              2015-03-25 03:57:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/556aca3e50ac
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.041148
Firmware Date          Wed Mar 25 04:11:58 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.2?
Whiteboard: [v2.2-nexus-5-l]
Naoki, you might be interested in this bug.
Flags: needinfo?(nhirata.bugzilla)
I am
Severity: normal → major
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
(In reply to Hermes Cheng[:hermescheng] from comment #2)
> I am

I do not know which product & component would be correct. Please correct it if my input is not correct.

Besides, I collect memory report but I think it is not helpful.


* Memory report - b2g-info
                            |      megabytes      |
           NAME   PID  PPID CPU(s) NICE   USS   PSS   RSS SWAP VSIZE OOM_ADJ USER     
            b2g 26505     1   72.7    0 103.1 116.2 144.3  0.0 362.8       0 root     
         (Nuwa) 26592 26505    0.5    0   4.1   6.9  22.2  0.0  69.3     -17 root     
     Homescreen 26824 26592   20.3    0  26.2  28.0  44.1  0.0 145.3       8 u0_a26824
Built-in Keyboa 27010 26505    2.3    0  12.7  16.8  31.2  0.0  91.9      12 u0_a27010
 Find My Device 27143 26592    1.3    0   7.1   8.8  23.5  0.0  77.8      12 u0_a27143
       Settings 27289 26592    6.0    0  16.0  18.2  34.7  0.0 117.2      11 u0_a27289
          Video 28224 26592    3.4    0  10.5  12.5  28.9  0.0 118.4      12 u0_a28224
        Browser 28574 26592    0.9    0   8.1   9.8  25.4  0.0 100.2      11 u0_a28574
    Marketplace 28786 26592    1.3    0  11.0  12.8  28.7  0.0 105.6      10 u0_a28786
         Camera 28891 26592    1.7    0  18.3  20.4  36.9  0.0 140.9       2 u0_a28891
(Preallocated a 28973 26592    0.1    0   4.1   6.2  18.0  0.0  73.5       1 u0_a28973

System memory info:

            Total 1856.0 MB
        SwapTotal    0.0 MB
     Used - cache  672.2 MB
  B2G procs (PSS)  256.8 MB
    Non-B2G procs  415.4 MB
     Free + cache 1183.8 MB
             Free 1046.2 MB
            Cache  137.7 MB
         SwapFree    0.0 MB

Low-memory killer parameters:

  notify_trigger -1 KB

  oom_adj min_free
Duplicate of this bug: 1147755
https://bugzilla.mozilla.org/show_bug.cgi?id=1123762 had landed on v2.2 the day before.  I tried turning off the pref and I can't seem to reproduce this bug at all.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(mchang)
Does this only occur on a Nexus 5 or also a flame now?
Assignee: nobody → mchang
Status: NEW → ASSIGNED
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(mchang)
Flags: needinfo?(hcheng)
Also, does this happen on master or only 2.2?
See Also: → 1144317
See Also: → 1147953
From the logcat:

D/skia    ( 1577): END /proc/cpuinfo
D/skia    ( 1577): Device supports ARM NEON instructions!
I/OMX-VDEC-1080P(  185): omx_vdec::component_deinit() complete
I/OMX-VDEC-1080P(  185): Exit OMX vdec Destructor: fd=17
I/Gecko   (  190): *** UTM:SVC TimerManager:notify - notified timerID: user-agent-updates-timer
I/GeckoConsole(  190): UTM:SVC TimerManager:notify - notified timerID: user-agent-updates-timer
I/Gecko   (  190): *** UTM:SVC TimerManager:registerTimer - id: user-agent-updates-timer
I/GeckoConsole(  190): UTM:SVC TimerManager:registerTimer - id: user-agent-updates-timer
E/sdcard  (  204): missing packages.list; retrying
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3
E/MP-Decision(  860): Error 1 setting online status to 1 forcpu3

That looks bad and unrelated. I see that error for CPUs 1-3.
(In reply to Mason Chang [:mchang] from comment #8)
> Also, does this happen on master or only 2.2?

Nexus 5 only but both on master and 2.2
Flags: needinfo?(hcheng)
This looks more like a hardware composer issue on L than anything with the vsync refresh driver. There looks like a potential race condition issue with enabling vsync and something in the gonk layer. Disable the vsync refresh driver on L until we sort out the hardware composer issues.
Attachment #8583931 - Flags: review?(bugmail.mozilla)
@Jerry - Can you please work with Hermes who also resides in Taipei to take a look at this? I don't have a Nexus 5 device. If you can't make progress on this, I can get a Nexus 5.
Flags: needinfo?(hshih)
Attachment #8583931 - Flags: review?(bugmail.mozilla) → review+
Flags: needinfo?(nhirata.bugzilla)
Keywords: qablocker
Comment on attachment 8583931 [details] [diff] [review]
Disable Vsync refresh driver on L devices

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Project Silk, bug 1123762
User impact if declined: Nexus 5 and other L devices will experience graphics issues such as stuttering.
Testing completed: Manual testing
Risk to taking this patch (and alternatives if risky): Low, this disables the vsync refresh driver on L devices
String or UUID changes made by this patch: None
Attachment #8583931 - Flags: approval-mozilla-b2g37?
I will check this issue.
Assignee: mchang → hshih
Flags: needinfo?(hshih)
This error message is weird. The ioctl write a cmd to device at [1], and the device node("/dev/graphics/fb0") already exists.

Diego, do you know why we got this error?

E/qdhwcomposer(  190): hwc_vsync_control: vsync control failed. Dpy=0, enable=1 : Operation not supported on transport endpoint

[1]
http://androidxref.com/5.1.0_r1/xref/hardware/qcom/display/msm8974/libhwcomposer/hwc_vsync.cpp#44
Flags: needinfo?(dwilson)
I turn on the vsync-rd with today's m-c build, but I don't get this issue. Still investigating.
blocking-b2g: 2.2? → 2.2+
I'd rather have a separate bug filed for disabling vsync refresh driver on L, as it will be easy to track since this bug is still going to be open to track the original issue with vsync refresh on.

For now, to unblock qa approving the patch and adding check-in needed.
Attachment #8583931 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Considering the disabling patch already landed as part of this bug it seems simpler to close this bug and do the work to re-enable it in a new bug.
Create Bug 1149480 to do the re-enable work.
Keywords: leave-open
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Please don't set checkin-needed on uplifts unless the bug only affects the branch and not master.
Keywords: checkin-needed
NI myself for following verification
Flags: needinfo?(hcheng)
Sorry guys, I was on PTO since the 27th. Let's follow up on bug 1149480
Flags: needinfo?(dwilson)
I tried below branches and can't reproduce this issue for now.

*2.2
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150402.035523
Firmware Date          Thu Apr  2 03:55:37 EDT 2015
Bootloader             HHZ12d

*master
Build ID               20150401180920
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37ddc5e2eb72
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150401.213532
Firmware Date          Wed Apr  1 21:35:45 EDT 2015
Bootloader             HHZ12d
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.