Closed Bug 1147792 Opened 5 years ago Closed 5 years ago

The soft keyboard can't be hidden and device directly enters homescreen when user inputs wifi password and taps OK icon.

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1148584
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.1S --- unaffected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: lixia, Unassigned)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

[1.Description]:
[Flame][v2.2&3.0][E.me Integration]Tap "No internet connection" on Rocketbar, input wifi password, then tap OK, then the soft keyboard can't be hidden, device directly enters homescreen, and wifi can not be connected successfully.
Found time:15:48
Attachment:rocketbar_wifi.mp4 and logcat1548.txt

[2.Testing Steps]: 
Preconditions:Has no a wifi network connection.

1.Tap on Rocketbar on Homescreen.
2.Input any words,then tap on "No internet connection" icon.
3.Tap Wi-Fi.
4.Select a wifi and input correct password,then tap OK icon.

[3.Expected Result]: 
4.The keyboard should be hided and device backs to wifi list,and wifi is connected successfully.

[4.Actual Result]: 
4.The keyboard is not hidden and device directly enters homescreen,and wifi can not be connected successfully.

[5.Reproduction build]: 
Device: Flame 2.2 build(Affected)
Build ID               20150325162500
Gaia Revision          2d42a7c1d99472780e3aeb2e16d7cb0a4adbd222
Gaia Date              2015-03-25 20:46:52
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ebb742bfe1a4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.200218
Firmware Date          Wed Mar 25 20:02:30 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Affected)
Build ID               20150325160204
Gaia Revision          508b8d48fb5ecf08bf0e5b4fef42bc48b770e7f2
Gaia Date              2015-03-25 16:54:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f40ee067d081
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150325.191758
Firmware Date          Wed Mar 25 19:18:07 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
occasionally Recurrence,6/20

[7.TCID]: 
Free test

[8.Note]:
User needs tap on "Rocketbar" and tap "Close" icon,then keyboard will be hidden.
Flags: needinfo?(hcheng)
Can we get a video?
Attached file logcat1548.txt
Attached video rocketbar_wifi.mp4
I can't repro this bug on latest Nightly Flame v2.1.

Device: Flame 2.1 build(Affected)
Build ID               20150326001202
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e00ae73d67a2
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.035122
Firmware Date          Thu Mar 26 03:51:33 EDT 2015
Bootloader             L1TC000118D0
I can't repro this bug on latest Nightly Flame v2.1 and v2.1S.

Device: Flame 2.1 build(Unaffected)
Build ID               20150326001202
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e00ae73d67a2
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.035122
Firmware Date          Thu Mar 26 03:51:33 EDT 2015
Bootloader             L1TC000118D0

Device: 2.1S_512mb (Uaffected)
Build ID               20150326161206
Gaia Revision          fa9fb90a3eaad9feff807249a925926626287908
Gaia Date              2015-03-25 15:44:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/0456171fdf24
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng)
Dale, can you take a look?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(dale)
Whiteboard: [systemsfe]
Will do
Assignee: nobody → dale
Flags: needinfo?(dale)
Summary: [Flame][E.me Integration]The soft keyboard can't be hidden and device directly enters homescreen when user inputs wifi password and taps OK icon. → The soft keyboard can't be hidden and device directly enters homescreen when user inputs wifi password and taps OK icon.
I have tried reproducing this and cant on 3.0 or 2.2 around 5 times each

If the issue does reproduce again then I this should likely be a keyboard or possibly settings bug, I cant think of any way for it be a search app issue
Assignee: dale → nobody
Component: Gaia::Search → Gaia::Keyboard
I also cannot reproduce this bug which I could 3 days ago. I would prefer close this bug, and please feel free to reopen it if it is still there.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Hi Dale & Hermes,

    I still can repro this bug on latest Flame v2.2&3.0. Please try again, thanks.
    The KEY steps easier to repro:
    (1)Before step 1,Settings app runs in the background.
    (2)In step 4,when you input wi-fi password,don't hide the keyboard and hold once it pops up,then tap OK icon.
Flags: needinfo?(hcheng)
Shally, I still can't. Could you please provide a video for your steps at comment 10?
Flags: needinfo?(hcheng)
Attached video new_video.mp4 (obsolete) —
Hi Hermes,

  New video uploads,please refer,thanks.
Attachment #8585326 - Attachment is obsolete: true
Attached video new_video.mp4
Its reproduced rate seems be less than 30%.
Rudy, could you take a look?
Status: RESOLVED → REOPENED
Flags: needinfo?(rlu)
Resolution: WORKSFORME → ---
This is a regression if this could not be reproduced on v2.1, according to comment 4.
Ask for QA's help to find regression window on v2.2 if possible.

Keyboard show/hide is controlled by system's input management, so change the component.
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
Flags: needinfo?(rlu)
Hi Sally, Could you help to find regression window, thank you.
Flags: needinfo?(lixia)
(In reply to Eric Chang [:ericcc] [:echang] from comment #16)
> Hi Sally, Could you help to find regression window, thank you.

Of course,I will.
Flags: needinfo?(lixia)
ni Arthur for comment
Flags: needinfo?(arthur.chen)
b2g-inbound Regression Window:

Last Working Environmental Variables - issue does NOT repro :
Gaia-Rev        858c3d4b2fcb30ed4c76fd57b75d0a23f138be19
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/04c0bfcb04d5
Build-ID        20150108051801
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150330.201412
FW-Date         Mon Mar 30 20:14:21 EDT 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables - issue DOES repro :
Build ID               20150108072311
Gaia Revision          0d000ae2fc7e966c9ecdc23d0c45c5e1ef84fec2
Gaia Date              2015-01-08 14:35:06
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/b4926227268f
Gecko Version          37.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro :
Build ID               20150108051801
Gaia Revision          0d000ae2fc7e966c9ecdc23d0c45c5e1ef84fec2
Gaia Date              2015-01-08 14:35:06
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/04c0bfcb04d5
Gecko Version          37.0a1

First Broken Gecko & Last Working Gaia - issue does NOT repro :
Build ID               20150108072311
Gaia Revision          858c3d4b2fcb30ed4c76fd57b75d0a23f138be19
Gaia Date              2015-01-08 12:55:20
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/b4926227268f
Gecko Version          37.0a1


Note:
1.logcat: logcat_1236(First Broken Gaia&Last Working Gecko).txt.
2.I can't repro this bug on build ID "20150108051801" (Rate:0/20)
Whiteboard: [systemsfe]
Once bug 1148584 is resolved, the current STR will become invalid. Although the real issue may still exist, but I think we can mark this bug as a duplicate of bug 1148584 for now.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(arthur.chen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1148584
The symptom is exactly the same as bug 859596 had shown. We have to blur the input in a proper time.
See Also: → 859596
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.