[RTL][Dialer] Arabic characters are cut off at the bottom in call log

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: azasypkin)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted image ArabicCutOff.png
Description:
Arabic characters are cut off at the bottom in the call log.

Repro Steps:
1) Update a Flame to 20150327010205.
2) Set the device language in Arabic under Settings > Language.
3) Open Dialer.
4) Call Voicemail, and hang up.
5) Go to Daier > Call log.
6) Observe the "voicemail" text in the call log.


Actual:
Arabic characters are cut off at the bottom.
(The two dots in "تي" are not shown.)

Expected:
Arabic characters are displayed completely. 

Notes:
This issue does NOT reproduce with Latin characters. The charaters like "g", "q", "y" are displayed properly.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150327010205 (KK, 319mb, full flash)
Gaia: 249b8c08c1d57961ef6c905f3498fa62b032bf24
Gecko: e046475a75cb
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: screenshot
Reporter

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: On the call log, the two dots in "تي" (lower left side) are not shown.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Reporter

Comment 2

4 years ago
Posted image Callscreen.png
This screenshot shows how the string is shown in call screen. The red box indicates the area that is cut off in the call log.
We should definitely not be having text cut off from the call log. Looking at the screenshot, seems like this is also happening on other text above (so not only the Voicemail string).
Nominating, and Triaging as P1. thanks
blocking-b2g: --- → 2.2?
Priority: -- → P1
triage: major issue on RTL
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → drs
Status: NEW → ASSIGNED
As we agreed with :drs on IRC, I'll look into the issue
Flags: needinfo?(azasypkin)
Stealing...
Assignee: drs → azasypkin
Flags: needinfo?(azasypkin)
Comment on attachment 8586036 [details] [review]
[gaia] azasypkin:bug-1148626-rtl-cut-arabic-chars > mozilla-b2g:master

Hey Doug,

Here's a quick fix for "high" Arabic chars in contact name/carrier/phone-tag displayed in call log.

The idea is similar to what we'll probably have in SMS as well (bug 1140977 comment 1) - we're increasing line-height and the rest of changes is just to preserve original look & feel.

Please, let me know if you have better idea in mind.

Thanks!
Attachment #8586036 - Flags: review?(drs)
Attachment #8586036 - Flags: review?(drs) → review+
Needinfo for uplift request.
Flags: needinfo?(azasypkin)
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15428/
Flags: in-moztrap+
Comment on attachment 8586036 [details] [review]
[gaia] azasypkin:bug-1148626-rtl-cut-arabic-chars > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a, RTL requirement
[User impact] if declined: some Arabic characters (in contact name, carrier name, phone type tag) will be cut off in call log. 
[Testing completed]: yes, manual
[Risk to taking this patch] (and alternatives if risky): low, small targeted CSS-only fix
[String changes made]: n/a
Flags: needinfo?(azasypkin)
Attachment #8586036 - Flags: approval-gaia-v2.2?
Depends on: 1150394
Attachment #8586036 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
No longer depends on: 1150394
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds.

Actual Results:  Arabic text is not cut off on the bottom in call log entries.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150408010203
Gaia: 84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gecko: 078128c2600a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150408002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 43041c78052b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
This bug could have been fixed by bug 1150449 too, so maybe you can try to revert it if you think this has other side-effects.
You need to log in before you can comment on or make changes to this bug.