Long labels in buttons are truncated instead of wrapping

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Components
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: tchevalier, Assigned: eragonj)

Tracking

unspecified
2.2 S10 (17apr)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8584844 [details]
Truncation in Settings > Browsing privacy in French

That's a recent regression on master, labels on buttons are now truncated while they were wrapping in multiple lines.

Tested on latest master build on Flame with French.

+ qawanted to check on 2.2, just to be sure it's not affected.
(Reporter)

Comment 1

3 years ago
Created attachment 8584845 [details]
Truncation in Settings > Devtools, in French
QA Contact: ktucker
Issue DOES reproduce on Flame 2.2 for both Browser Privacy and Devtools truncated strings.

"Effacer les cookies et les donnees..." and "Reinitialiser et activer les outils de..." are truncated.

Device: Flame 2.2(Full Flash)(KK)(319mb)
Build ID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: ? → affected
Keywords: qawanted, regression
(Reporter)

Comment 3

3 years ago
Argh, thanks Kevin!

Nominating for 2.2 then, a lot of UI pieces are affected, and in most of the cases, the user can't/will have hard time to understand what the button does.

Also, I think it should be quite easy to fix.
blocking-b2g: --- → 2.2?

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+

Comment 4

3 years ago
ni Arthur for comment.
Flags: needinfo?(arthur.chen)
It is unlikely to have multi-row buttons. Possible options would be reducing the font size or replacing the string with a shorter one. 

Stephany, is there any policy handling this kind of issues?
Flags: needinfo?(arthur.chen) → needinfo?(swilkes)
(Reporter)

Comment 6

3 years ago
Hi Arthur,

This is a regression, buttons _were_ multi-row a few days ago, I think we could just back out the patch that caused this regression.
We can't change strings on 2.2 anymore.
Flags: needinfo?(swilkes)
The bug was regressed by another 2.2 blocker bug 1145835 so I'm afraid that we can't simply revert it.

EJ, it seems there are conflicts on the loading sequence between these two bugs. Any idea?
Flags: needinfo?(ejchen)
Created attachment 8590609 [details] [review]
[gaia] EragonJ:bug-1148645 > mozilla-b2g:master
Comment on attachment 8590609 [details] [review]
[gaia] EragonJ:bug-1148645 > mozilla-b2g:master

Arthur, I think what we did in previous 2.2 patch is right and no need to backout. With that patch, buttons and some shared styles are loaded at first before lists.css and this is definitely right !

For me, I think the main problem is that we force to make all "ul li > *" "text-overflow: ellipsis;" and this would definitely influence multi-line buttons. 

So for this 2.2 bug, as a quickfix, I think it's acceptable to override "ul li button" (Yes, we did have this rule, so what I do here is add one more attribute).

Because styles in Settings App is getting in a state of chaos, I think we can try to survey what we can do to make it look better.

Any idea would be appreciated !
Flags: needinfo?(ejchen)
Attachment #8590609 - Flags: review?(arthur.chen)
Assignee: nobody → ejchen
Comment on attachment 8590609 [details] [review]
[gaia] EragonJ:bug-1148645 > mozilla-b2g:master

I agree that for this time being overriding makes a lot sense. r=me, thanks!
Attachment #8590609 - Flags: review?(arthur.chen) → review+
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1153115
Thanks Arthur, this patch was merged into Gaia/master :  https://github.com/mozilla-b2g/gaia/commit/3f6db9c25557e73f831e749a0c5621c685330507
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Comment on attachment 8590609 [details] [review]
[gaia] EragonJ:bug-1148645 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1145835
[User impact] if declined: some buttons with multi-lines translations would be truncated.
[Testing completed]: yes, with manual tests.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8590609 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8590609 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/c1dcb2287ac40fb6d195e82ee272e7e0a7b22b8b
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds.

Actual Results: The text now wraps instead of truncating.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150416010206
Gaia: 629097847567e51095a454e7e63186a6e2ac0307
Gecko: a35163f83d22
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150416002504
Gaia: 8e24d8b7f5e7c74c3004b22710dda0dac3e04ead
Gecko: 41388836b5c6
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.