[STK] No Terminal Response received for [SETUP EVENT LIST: Browser Termination] proactive command

RESOLVED FIXED in 2.2 S10 (17apr)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: selee)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 814242][ft:comms])

Attachments

(5 attachments)

Reporter

Description

4 years ago
STR:

- Run USAT GCF 27.22.7.9.1.1
- Card sends SET UP EVENT LIST: Browser Termination proactive command.

Expected: Terminal response for the set up event list
Observed: No terminal response being sent
Reporter

Comment 1

4 years ago
This seems like a regression from bug 1088611 where the code to send terminal response is explicitly removed.
Whiteboard: [caf priority: p2][CR 814242]

Comment 2

4 years ago
Hi Wesley, are you in charge of the STK and triage this? Thanks.
Flags: needinfo?(whuang)
Hi Sean,
Can you look into this? (comment 1)
Flags: needinfo?(selee)
Assignee

Comment 4

4 years ago
Flags: needinfo?(selee)
Assignee

Comment 5

4 years ago
Comment on attachment 8586579 [details]
Trial Patch for v2.2

Hi Anshul,

Could you try the patch?
I add the TR back.

Thank you.
Attachment #8586579 - Attachment description: T → Trial Patch for v2.2
Flags: needinfo?(anshulj)
Very likely this will be a blocker, but would like to hear from devs first.
We're very close to FC date (April6th).

Updated

4 years ago
Whiteboard: [caf priority: p2][CR 814242] → [caf priority: p2][CR 814242][ft:comms]
Reporter

Comment 7

4 years ago
(In reply to Sean Lee [:seanlee] from comment #4)
> Created attachment 8586579 [details]
> Trial Patch for v2.2

Sean, would you know why this TR was removed in bug 1088611. I don't have access to the bug so don't know the history.
Assignee

Comment 8

4 years ago
(In reply to Anshul from comment #7)
> Sean, would you know why this TR was removed in bug 1088611. I don't have
> access to the bug so don't know the history.

This is caused by another device's modem chip design.
The modem chip will send the TR for SET_UP_EVENT proactive command.
Assignee

Comment 9

4 years ago
This is a mistake that the TR for SET_UP_EVENT proactive command is removed.
So I think this should be added back.
Reporter

Updated

4 years ago
Flags: needinfo?(anshulj)
Attachment #8586579 - Flags: feedback+
Comment hidden (obsolete)
Comment on attachment 8588402 [details] [review]
PR for v2.2

Hi Fernando,

Could you help to review my PR?
Thank you very much.
Comment on attachment 8588402 [details] [review]
PR for v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1088611
[User impact] if declined:
We won't pass STK test.
The current design is for a specific MODEM chip, not a generic one.
see comment 8

[Testing completed]:
Report has been accepted this changes.

[Risk to taking this patch] (and alternatives if risky):
Only sending a TR for SET_UP_EVENT. Very minor risky.

[String changes made]:
None
Attachment #8588402 - Flags: approval-gaia-v2.2?
Attachment #8588402 - Flags: review?(frsela) → review+
Reporter

Comment 14

4 years ago
Bhavna, could you please approve the uplift?
Flags: needinfo?(bbajaj)
Flags: needinfo?(bbajaj)
Attachment #8588402 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(whuang)
Reporter

Updated

4 years ago
Blocks: 1162224
Was v3.0 unaffected here?
Assignee: nobody → selee
Flags: needinfo?(selee)
Target Milestone: --- → 2.2 S10 (17apr)
Posted file PR for master
Hi Ryan, This is by modem chip design to send TR or not, so my opinion is adding the code to send TR. If there is any design changed for specific chip, we can customize it at device branch. Thank you.
Flags: needinfo?(selee)
You need to log in before you can comment on or make changes to this bug.