[Flame][Window Management]When you are in "Confirm" screen of installing app, Swip the screen, and the screen is still in current, while these apps in background are switched in actual.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: lixia, Assigned: evanxd)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

[1.Description]:
According to Bug 1144054 in Comment 23, this bug is filed.
[Flame][v2.2&3.0][Window Management]When you are installing an app, in confirm screen, you can't switch apps by swipping screen on foreground, and these apps are switched on background actually.
Found at:04:20
Attach:switch_install_view.mp4 and logcat_0420.txt.

[2.Testing Steps]: 
1.Run some apps in the background.
2.Launch Marketplace.
3.Select an app to install
**It will enter the Confirm screen.
4.Slide from the left/ right edge to the right/ left.
**Can not switch the recent apps on the background as expected.
5.Long tap Home button.
6.Select and tap an app in task manager.
7.Repeat step 4.

[3.Expected Result]: 
6.This app that you select in task manager is opened and reveals to user.
7.Can not switch these recent apps in the background.

[4.Actual Result]: 
6.It shows the "Confirm" screen of installing app
7.Can switch these recent apps in the background ,which reveals on the notification bar,but it still shows in install app view, that confuses the user.

[5.Reproduction build]: 
Device: Flame 2.2 build(Affected)
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Affected)
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 1

[6.Reproduction Frequency]: 
Always Recurrence,6/6

[7.TCID]: 
Free Test

[8.Note]:
The install cancellation screen also exists this bug.
(Reporter)

Updated

4 years ago
See Also: → 1144054
(Reporter)

Comment 1

4 years ago
Posted file logcat_0420.txt
Incorrect window activity.
Nominate it.
blocking-b2g: --- → 2.2?
Can we re-test this to see if this is fixed/improved , given the landing in 1144054?
Flags: needinfo?(lixia)
blocking-b2g: 2.2? → 2.2+
Keywords: qawanted
(Reporter)

Comment 5

4 years ago
Hi All,

    By the STR of Comment 0,I am able to repro this bug on latest Nightly Flame v2.1&2.2&3.0 (Rate:5/5), but can't repro on latest Flame v2.0 (Rate:0/5).

Actual results: On the "Confirm" screen of installing app, user can switch recent apps on background actually.


Note:
On Flame v2.1,the problem of Bug 1144054 still exists.
-----------------------------------------------------------------------
Device: Flame 2.0 build(Unaffected)
Gaia-Rev        84898cadf28b1a1fcd03b726cff658de470282f0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e4014ac859af
Build-ID        20150406160207
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150406.194235
FW-Date         Mon Apr  6 19:42:44 EDT 2015
Bootloader      L1TC000118D0

Device: Flame 2.1 build(Affected)
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 build(Affected)
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Affected)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lixia)
Keywords: qawanted
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
Alive, Etienne, can you help out here?
Flags: needinfo?(etienne)
Flags: needinfo?(alive)

Updated

4 years ago
Whiteboard: [systemsfe]
Flags: needinfo?(timdream)
Whiteboard: [systemsfe]
Looks like Etienne is not around.

Evan, could you help?
Flags: needinfo?(alive) → needinfo?(evanxd)
Etienne/Evan is on it.
Flags: needinfo?(timdream)
(Assignee)

Comment 9

4 years ago
Sure.
Assignee: nobody → evanxd
Flags: needinfo?(evanxd)
Thanks!
I think the holdhome event should have the same behavior than just pressing home (ie. canceling the install).
See https://github.com/mozilla-b2g/gaia/blob/b51a012ca71416e0660f08797ca9130645d765fe/apps/system/js/app_install_manager.js#L118
Flags: needinfo?(etienne)
(Assignee)

Comment 11

4 years ago
Thanks, Etienne.
The patch fixed the bug.
Adding and updating tests now.
(Assignee)

Comment 12

4 years ago
Added and updated tests.
Waiting for CI results.
Then we could start to review the patch. :)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8591531 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/29471

Hi Etienne,

Could you help to review the patch?

Thanks.
Attachment #8591531 - Flags: review?(etienne)
Comment on attachment 8591531 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/29471

Looking good, thanks!
r=me with the small test change, let me know if anything is unclear.

Cheers!
Attachment #8591531 - Flags: review?(etienne) → review+
(Assignee)

Comment 15

4 years ago
Sure, thanks for the review.
I already updated the tests.
Waiting for CI.
(Assignee)

Comment 17

4 years ago
Comment on attachment 8591531 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/29471

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): None.
[User impact] if declined: Could not switch to specific app in task manager when user is in app installation page.
[Testing completed]: CI is good, and works in local device.
[Risk to taking this patch] (and alternatives if risky): Low, patch only has three lines changed.
[String changes made]: None.
Attachment #8591531 - Flags: approval-gaia-v2.2?(bbajaj)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment #8591531 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2&3.0.

Actual results:
1.On "Confirm" screen of installing app or "Cancel" installing app,slide from the left/ right edge to the right/ left, these recent apps in background can't be switched as expected.
2.Long tapping Home button,device will exit the "Confirm" screen of installing app automatically.And then selecting other recent app to open in task manager,device will enter the corresponding app screen as expected. 

See attachment: verified_v2.2&3.0.mp4
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0
Hi Josh,

This bug is a regression. Could you check whether to uplift to flame  2.1?
Thanks.
Flags: needinfo?(jocheng)

Updated

4 years ago
Flags: needinfo?(jocheng)
Keywords: regression
Hi Evan,
Could you help to raise 2.1 Uplift approval as this is regression issue?
Thanks!
Flags: needinfo?(evanxd)
The v2.2&master has verified, so clear 'verifym' keywords.
Keywords: verifyme
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Flags: needinfo?(evan)
You need to log in before you can comment on or make changes to this bug.