Closed Bug 1148923 Opened 5 years ago Closed 5 years ago

[ja] Subdialog default width of in-content preferences is too narrow in ja locale

Categories

(Firefox :: Preferences, defect)

38 Branch
x86_64
Windows 7
defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 40
Iteration:
40.2 - 27 Apr
Tracking Status
firefox37 --- unaffected
firefox38 + fixed
firefox39 + fixed
firefox40 + fixed

People

(Reporter: alice0775, Assigned: Gijs)

References

Details

(Keywords: intl, jp-critical)

Attachments

(9 files)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Steps To Reproduce:
1. Tools > Options > Content > [Advanced...]
   ツール > オプション > コンテンツ > [詳細設定]
   --- observe width of the subdialog and font select box

2. Click a font select box
   --- observe width of the dropdown and option labels

Actual Results:
Subdialog default width and the font select box is too narrow in ja build

Expected Results:
These width should be wider as much as in en-US
IIRC localizers don't have any way to set that width. If I'm right this bug should be in Firefox -> Preferences, since there's nothing localizers can't do to fix it.
Component: ja / Japanese → Preferences
Product: Mozilla Localizations → Firefox
QA Contact: l10n-qa
Version: unspecified → Firefox 38
Version: Firefox 38 → 38 Branch
Seems like we should set a min-width on the font dropdown. AFAICT the reason this works on en-US is that the text lower down in the dialog is forcing a wider dialog.
(we could add a width entity, but that doesn't port to 38)
Until we find a solution that we can uplift (as well as understand the root cause of this issue), can you try adding some non-breaking spaces to your locale files to give more width to the dialog? You could add them to the &languages.customize.Fallback2.grouplabel; and until you get a width that is desired.

Flod, could that work for JA? If so, do you know who to forward this to on the ja-locale side?
Flags: needinfo?(francesco.lodolo)
Abe, can you take a look this bug?
Flags: needinfo?(francesco.lodolo) → needinfo?(h.rayflood)
Any update here?
Depends on: 1153403
Attached image Reproduced on 38.0b3
Still reproduced.
Attached image Firefox37.png
No problem on Firefox37
I wonder if the browser's window size matters. Also Alice's image uses Windows Classic theme, Abe's doesn't.
not reproduced when classic theme.
any conditions?
Please compare with width of other language and normal dialog version(prior to 37).
Font subdialog on Ja locale is much narrower than the others.
indeed, ja locale is narrower than en-us.
but, does not look much narrow for me.

any concrete conditions?
classic, system font MS UI Gothic, size 11.
As preferences in-tab is a new feature (from the Release POV), it would be nice if this bug could be fixed for 38.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 40.2 - 27 Apr
Points: --- → 2
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
Arguably this is a pretty font+language-specific issue, but this fixes things to an acceptable degree for me (this is a patch against beta which I suspect will be easy to run on m-c as well). Tested against beta with the japanese language pack. Obviously if you have very long font names, 30ch is still not going to be enough, but it should be OK for most disambiguation.

(r?mconley because jaws isn't accepting reviews)
Attachment #8592838 - Flags: review?(mconley)
Comment on attachment 8592838 [details] [diff] [review]
Min-width the font selectors

Review of attachment 8592838 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, this is a low-risk fix that we can uplift to beta.
Attachment #8592838 - Flags: review?(mconley) → review+
Comment on attachment 8592838 [details] [diff] [review]
Min-width the font selectors

Approval Request Comment
[Feature/regressing bug #]: in-content prefs
[User impact if declined]: japanese locale with some fonts has a too-narrow fonts dialog
[Describe test coverage new/current, TreeHerder]: nope :-(
[Risks and why]: very low, CSS change to fix the width of the fonts dropdowns
[String/UUID change made/needed]: nope
Attachment #8592838 - Flags: checkin+
Attachment #8592838 - Flags: approval-mozilla-beta?
Attachment #8592838 - Flags: approval-mozilla-aurora?
Comment on attachment 8592838 [details] [diff] [review]
Min-width the font selectors

Not waiting for the patch to be in m-c to make sure it is in 38 beta 5.
Attachment #8592838 - Flags: approval-mozilla-beta?
Attachment #8592838 - Flags: approval-mozilla-beta+
Attachment #8592838 - Flags: approval-mozilla-aurora?
Attachment #8592838 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/a6b4ae672ec9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
I verified that this was fixed on 38.0b5.
https://hg.mozilla.org/releases/mozilla-beta/rev/90271e6d8250
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150416143048
You need to log in before you can comment on or make changes to this bug.