test_music_album_mp3.py: "NoSuchElementException: NoSuchElementException: Unable to locate element: span.list-song-index"

RESOLVED DUPLICATE of bug 1149886

Status

defect
RESOLVED DUPLICATE of bug 1149886
4 years ago
4 years ago

People

(Reporter: onelson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
Description:
test_music_album_mp3.py failed to perform the task "sublist_view = albums[0].tap_first_album()", opened the music app to the corresponding view but could not detect or tap the UI. Issue reproed 5/5 times in a Jenkins adhoc run.

http://jenkins1.qa.scl3.mozilla.com/user/oliverthor/my-views/view/Smoke%20Team%20Reporting/job/flame-kk.ui.adhoc/758/HTML_Report/

Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/music/test_music_album_mp3.py", line 35, in test_select_album_play
    sublist_view = albums[0].tap_first_album()
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/music/regions/list_view.py", line 37, in tap_first_album
    return SublistView(self.marionette)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/music/regions/sublist_view.py", line 19, in __init__
    element = self.marionette.find_element(*self._song_number_locator)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 1448, in find_element
    response = self._send_message('findElement', 'value', **kwargs)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 670, in _send_message
    self._handle_error(response)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/marionette.py", line 709, in _handle_error
    raise errors.NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: span.list-song-index

Issue DOES NOT REPRODUCE manually - 5/5 passing
Reporter

Comment 1

4 years ago
Issue seems extremely similar to that seen in bug 1149207 (mentioned in See Also), where the 'Artist' field is having difficulties pulling the first artist UI: possible rename of html passed?
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
See Also: → 1149207
Reporter

Comment 2

4 years ago
test_music_album_mp3 fails to select album: "sublist_view = albums[0].tap_first_album()"
Summary: test_music_album_mp3 fails to select album: "sublist_view = albums[0].tap_first_album()" → test_music_album_mp3.py: "NoSuchElementException: NoSuchElementException: Unable to locate element: span.list-song-index"
I suspect this is also a regression from bug 1075670.
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Will be fixed in bug 1149886
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149886
You need to log in before you can comment on or make changes to this bug.