bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

test_calendar_flick_through_months.py: "TimeoutException: TimeoutException: Timed out after 20.1 seconds"

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Description:
test_calendar_flick_through_months.py failed to flicck through the months in it's UI in todays mozilla-central.non-smoke run. Screenshot shows device opened calendar and could not transition between months. Issue reproed 5/5 times in an additional adhoc Jenkins run.

http://jenkins1.qa.scl3.mozilla.com/user/oliverthor/my-views/view/Smoke%20Team%20Reporting/job/flame-kk.ui.adhoc/758/HTML_Report/

Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/calendar/test_calendar_flick_through_months.py", line 28, in test_calendar_flick_through_months
    calendar.flick_to_next_month()
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/calendar/app.py", line 245, in flick_to_next_month
    self._flick_to_month('next')
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/calendar/app.py", line 278, in _flick_to_month
    Wait(self.marionette).until(lambda m: self.current_month_year != month_year)
  File "/var/jenkins/2/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.1 seconds

Issue DID NOT REPRODUCE manually - 10/10 passing
(Reporter)

Comment 1

3 years ago
Issue seems similar to that seen in bug 1149202 affecting test_gallery_flick, transitioning between images.
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
See Also: → bug 1149202
Depends on: 1149167
(Reporter)

Comment 2

3 years ago
test_calendar_flick_through_months failed to flick through months: "calendar.flick_to_next_month()"
Summary: test_calendar_flick_through_months failed to flick through months: "calendar.flick_to_next_month()" → test_calendar_flick_through_months.py: "TimeoutException: TimeoutException: Timed out after 20.1 seconds"
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Can't repro anymore since bug 1075670 was backed out.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.