Closed Bug 1149226 Opened 5 years ago Closed 5 years ago

Reading List sync check box is deselected (off) after Nightly update

Categories

(Android Background Services Graveyard :: Reading List Sync, defect)

All
Android
defect
Not set

Tracking

(firefox38 verified, firefox39 verified, firefox40 verified, fennec38+)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox38 --- verified
firefox39 --- verified
firefox40 --- verified
fennec 38+ ---

People

(Reporter: edwong, Assigned: nalexander)

References

Details

Attachments

(1 file)

No description provided.
STR:
1. add items to RL (not synced from an old build of Nightly  Mar 28 or earlier)
2. upgrade Nightly to latest Mar 30 or later)
3. go into Settings > Sync
4. look at sync data types

actual: Reading List checkbox is unchecked (sync off).

expected: it should be checked (sync on)
Confirmed locally.  I will get on this.
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
tracking-fennec: --- → 38+
Nick: this is the last blocker to turning RL sync on in Aurora and Beta.
Blocks: 1123389, 1123377
For QA: (From the commit message.)
    
    The desired behaviour is: Reading List is syncing automatically if
    Firefox Sync is syncing automatically.
    
    Test plan: remove all Firefox Accounts.
    
    1) Install old version.  Add a Firefox Account.  Ensure that Firefox
    Sync is enabled.  Upgrade to new version.  Verify that Reading List is
    enabled.
    
    2) Install old version.  Add a Firefox Account.  Manually disable
    Firefox Sync by unchecking the checkbox in Android Settings >
    Accounts.  (This can not be done from the Firefox Account settings
    activity; unchecking the 4 boxes there is not the same.)  Upgrade to new
    version.  Verify that Reading List is disabled.
    
    3) Install new version.  Add a new Firefox Account.  Verify that Reading
    List is enabled.
    
    (There are automated tests for these scenarios.)
Attachment #8587719 - Flags: review?(rnewman)
rnewman: here's a fresh commit.  More to your liking?
Flags: needinfo?(rnewman)
Comment on attachment 8587719 [details] [review]
Pull req (wrong bug number)

rnewman reviewed on IRC.
Flags: needinfo?(rnewman)
Attachment #8587719 - Flags: review?(rnewman) → review+
Comment on attachment 8587719 [details] [review]
Pull req (wrong bug number)

Approval Request Comment
[Feature/regressing bug #]:
  Remaining reading list work.

[User impact if declined]:
  Reading list sync will be disabled by default for existing FxA users.

[Describe test coverage new/current, TreeHerder]:
  Tests added. Manually tested in context. Just landed in fx-team; this approval request assumes everything goes green.

[Risks and why]: 
  As low risk as we could make it. Some intrinsic risk, because it involves touching the Android accounts system. So it goes.

[String/UUID change made/needed]:
  None.
Attachment #8587719 - Flags: approval-mozilla-beta?
Attachment #8587719 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7bd682f7d759
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Comment on attachment 8587719 [details] [review]
Pull req (wrong bug number)

Should be in 38 beta 2
Attachment #8587719 - Flags: approval-mozilla-beta?
Attachment #8587719 - Flags: approval-mozilla-beta+
Attachment #8587719 - Flags: approval-mozilla-aurora?
Attachment #8587719 - Flags: approval-mozilla-aurora+
Note that for this -- or the feature at all -- to be in B2, we need approval for Bug 1123389.
Verified as fixed on latest Nightly 40.0a1 and Aurora 38.0a2
Still needs to be verified on Firefox 38 Beta 4
Verified as fixe(In reply to Nick Alexander :nalexander from comment #4)
> For QA: (From the commit message.)
>     
>     The desired behaviour is: Reading List is syncing automatically if
>     Firefox Sync is syncing automatically.
>     
>     Test plan: remove all Firefox Accounts.
>     
>     1) Install old version.  Add a Firefox Account.  Ensure that Firefox
>     Sync is enabled.  Upgrade to new version.  Verify that Reading List is
>     enabled.
>     
>     2) Install old version.  Add a Firefox Account.  Manually disable
>     Firefox Sync by unchecking the checkbox in Android Settings >
>     Accounts.  (This can not be done from the Firefox Account settings
>     activity; unchecking the 4 boxes there is not the same.)  Upgrade to new
>     version.  Verify that Reading List is disabled.
>     
>     3) Install new version.  Add a new Firefox Account.  Verify that Reading
>     List is enabled.
>     
>     (There are automated tests for these scenarios.)

All three scenarios are working as expected on Beta 38.0b3  
Verifying as fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.