amazon.com search pages now display URL as page title in e10s

RESOLVED DUPLICATE of bug 1140129

Status

()

RESOLVED DUPLICATE of bug 1140129
4 years ago
4 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression, reproducible})

unspecified
x86
All
regression, reproducible
Points:
---

Firefox Tracking Flags

(e10sm7+, firefox37 unaffected, firefox38 affected, firefox39 affected, firefox40 affected)

Details

(Reporter)

Description

4 years ago
Dave: could this be a regression from bug 1081891?

I bisected this pushlog in Nightly 38 build 2015-02-21:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dbfe4013530a&tochange=71fff9b44fbe

STR:
1. Load http://www.amazon.com/
2. Search for something

RESULT:
The Amazon search page's title switches a lot and then settles on the URL instead of "Amazon.com: whatever".
Flags: needinfo?(dtownsend)
(Reporter)

Updated

4 years ago
status-firefox37: --- → unaffected
status-firefox38: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
Seems pretty likely yes, thanks for tracking that down.
Blocks: 1081891
Flags: needinfo?(dtownsend)

Updated

4 years ago
OS: Mac OS X → All

Updated

4 years ago
tracking-e10s: ? → m7+

Comment 3

4 years ago
I also experience the issue on the YouTube homepage on a just updated custom build, Windows 7 64-bit.

Comment 4

4 years ago
Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

This issue occurs on many other sites as well. 
Simply loading the page can be enough to see the URL instead of the page title.

An interesting example of this issue is on the http://www.fiawec.com/ website.

Go to http://www.fiawec.com/races/6-hours-of-silverstone.html and page title is shown normally
Go to http://www.fiawec.com/races/6-hours-of-silverstone/news.html and URL is shown instead of page title

What's the difference between these two rather similar pages on the same site?
I suspect we fixed this already. Please re-open if it still happens.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1140129
You need to log in before you can comment on or make changes to this bug.