Closed Bug 1140129 Opened 5 years ago Closed 5 years ago

[e10s] Tab title not always updated

Categories

(Firefox :: General, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
e10s m7+ ---
firefox40 --- fixed

People

(Reporter: vladan, Assigned: billm)

References

Details

Attachments

(1 file)

Sometimes, when I open Google Calendar (as a signed in user), the tab's title remains stuck on the page's URL and never updates to "Mozilla - Calendar". 

- There are no relevant errors or warnings in the browser console
- I can't reproduce this anymore, but I've seen it several times in the past
- Installed extensions: Send Tab to Device, Pocket
- I suspect this is e10s related but I'm not 100% sure
I've seen this kind of a lot recently.
I haven't noticed this problem, but I have noticed a related issue on Mac where opening the calendar page will show the tab title, but after a minute or so the page will do some fetching, and then the tab title will change to the URL. It won't display a "Mozilla - Calendar" tab title until you refresh the page.

If you try this on a non-e10s window, you don't see this problem.
I can also reproduce this on Google Calendar. I suspect that this is happening when the content updates the URL by changing the anchor.
Needinfo'ing myself to see if this is related or can be fixed together with bug 1129564
Depends on: 1129564
Flags: needinfo?(felipc)
My suspicion might be incorrect - updating the anchor via different means (<a href="#foo">, location.replace, location.hash, etc) don't seem to cause the bug to show. Odd.
I needinfo'ed myself to see if this was related to bug 1129564 - the conclusion is that it isn't.
No longer depends on: 1129564
Flags: needinfo?(felipc)
Attached patch patchSplinter Review
This was annoying me so I looked into it. The problem is that we can get onLocationChange events even when we're not navigating (changing the hash part of the URL for example). In that case we don't want to clear the title.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8589972 - Flags: review?(dtownsend)
Comment on attachment 8589972 [details] [diff] [review]
patch

Review of attachment 8589972 [details] [diff] [review]:
-----------------------------------------------------------------

Ah of course!
Attachment #8589972 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/mozilla-central/rev/00edb9fedb4c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Duplicate of this bug: 1149394
You need to log in before you can comment on or make changes to this bug.