Hangs/freezes when deleting indented text in show all tags view

VERIFIED DUPLICATE of bug 113290

Status

--
critical
VERIFIED DUPLICATE of bug 113290
17 years ago
14 years ago

People

(Reporter: TucsonTester1, Unassigned)

Tracking

({hang})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6+)
Gecko/20011210 Netscape6/6.2.1+
BuildID:    2001121003

When indenting a bunch of times, then deleting the text and some of the indents
in Show All Tags view, Composer freezes up.

Reproducible: Always
Steps to Reproduce:
1. Launch Composer
2. Type in 15 characters
3. Hit indent 25 times
4. Click on the Show All Tags tab
5. By clicking and dragging, highlight the text and the blockquote tags (the
blockquote tags won't appear to highlight)
6. Press delete

Actual Results:  After delete is pressed, Composer freezes.  This is also
noticeable with images, when they are indented multiple times (I've had pictures
freeze on me with just 15 indents).

Expected Results:  The text should be deleted without Composer freezing.

This was reproduced on two other machines, one using 95 OSR 2.5, and one using 98SE.

Comment 1

17 years ago
is this still a problem in a recent build?
Keywords: hang

Comment 2

17 years ago
Tucson/Michael, please re-try on latest build.

Comment 3

17 years ago
I am still seeing this problem on Win 2k using trunk build 2002012103.

I am confirming this bug.

One thing to note, in step 3 you have to hit the indent button on the toolbar,
if you hit the tab key, you will get a different issue. Which is reported in bug
121237.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 113290 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
reassign bugs in case they are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.