[Flame][Settings]There isn't the button to turn on data roaming.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jihao, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2&3.0][Settings] There isn't the button to turn on data roaming, only "Not now" button.
Attchment:159.png, 159.mp4 and logcat_159.txt
Happen time:1:59 PM

[2.Testing Steps]: 
1. Insert an non-local SIM card.
2. Power on
3. Slide down the notification bar
4. Tap "E" to try to turn on mobile data.

[3.Expected Result]: 
4. There should be a button to confirm to turn on data roaming.

[4.Actual Result]: 
4. A prompt box pops up, but there is no button to comfirm to turn on data roaming.

[5.Reproduction build]: 
Flame 2.2 (affected)
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.201412
Firmware Date          Mon Mar 30 20:14:21 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (affected)
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
(Reporter)

Comment 1

4 years ago
Posted video Bug video: 159.mp4
(Reporter)

Comment 2

4 years ago
Hi Peter, Do you have a foreign sim card to confirm this, thanks.
Flags: needinfo?(pbylenga)
I cannot, the foreign sim I have gives me the box outline for data and can't be toggled on notification tray.  I can enable it via settings.  Tried all network types in settings and also SIM slot 2.

Adding qawanted to see if someone can help out with this repro.
Flags: needinfo?(pbylenga)
Keywords: qawanted
[Blocking Requested - why for this release]: Functionality broken.
blocking-b2g: --- → 2.2?
Hi Paladin, Could you also check on V2.1, thank you.
Flags: needinfo?(jihao)
Hi Eric,

    By the same steps and same SIM card (Shanghai CMCC) in Comment 0,I am unable to repro this bug on latest Flame v2.1 (rate:0/6).


Device: Flame 2.1 build(Unaffected)
Build ID               20150408161201
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b016448b6076
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150408.195312
Firmware Date          Wed Apr  8 19:53:23 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jihao)

Comment 8

4 years ago
ni Arthur to check on this
Flags: needinfo?(arthur.chen)
The dialog is displayed in system app, change the component.

Alive, could you help find someone familiar with this module check the issue? Thanks.
Component: Gaia::Settings → Gaia::System
Flags: needinfo?(arthur.chen) → needinfo?(alive)
It seems just lack of `data-items=2`.
(In reply to Arthur Chen [:arthurcc] from comment #10)
> It seems just lack of `data-items=2`.

Yes, and I think it's going to be fixed in my roaming dialog patch (bug 1121356) for master (but I have no time to finish it right now.)
Flags: needinfo?(alive)
blocking-b2g: 2.2? → 2.2+
I see the same thing as peter does in comment 4 when attempting to confirm this bug.  I believe it is because the roaming SIM cards that we have are not set up for data, just calls/sms.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150410122439
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: eb3a1c0262e4
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QAnalysts can't do this bug (see comment 12). Adding tag to exclude this bug from our queries.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+], QAExclude
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #11)
> (In reply to Arthur Chen [:arthurcc] from comment #10)
> > It seems just lack of `data-items=2`.
> 
> Yes, and I think it's going to be fixed in my roaming dialog patch (bug
> 1121356) for master (but I have no time to finish it right now.)

Tim, can you find an owner here?
Flags: needinfo?(timdream)
Comment on attachment 8592589 [details] [review]
[gaia] crh0716:1149443 > mozilla-b2g:master

A quick fix as it becomes a blocker. Alive, could you help check the patch? Thanks.
Flags: needinfo?(timdream)
Attachment #8592589 - Flags: review?(alive)
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
Comment on attachment 8592589 [details] [review]
[gaia] crh0716:1149443 > mozilla-b2g:master

(Y)
Attachment #8592589 - Flags: review?(alive) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(arthur.chen)
Target Milestone: --- → 2.2 S10 (17apr)
Comment on attachment 8592589 [details] [review]
[gaia] crh0716:1149443 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users are not able to turn on data roaming using this dialog.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. It simply adds a missing attribute.
[String changes made]: None
Flags: needinfo?(arthur.chen)
Attachment #8592589 - Flags: approval-gaia-v2.2?
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.

Actual results: It will show the data roaming message with "Not Now" and "Turn On" button.
See attachment: verified_v3.0.png.
Reproduce rate: 0/5

Device: Flame 3.0 build(Pass)
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.191700
Firmware Date          Thu Apr 16 19:17:10 EDT 2015
Bootloader             L1TC000118D0
Attachment #8592589 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.

Actual results: It will show the data roaming message with "Not Now" and "Turn On" button.
See attachment: verified_v2.2.png.
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+], QAExclude → [QAnalyst-Triage+], QAExclude,[MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.