[RTL][Browser]The ellipsis is shown at left side of the URL text.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: sfoster)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Posted image Browser_URL.png
[1.Description]:
[RTL][v2.2 & v3.0][Browser]The ellipsis is shown at left side of the URL text which is in LTR language.
See attachment:Browser_RTL.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Browser.
3. Go to "www.youtube.com" and select a video.
4. Observe the URL in search bar.
5. Long press at Home button.
6. Observe the title in card view.

[3.Expected Result]: 
4&6. The ellipsis should be shown at right side of text which is in LTR language.

[4.Actual Result]: 
4&6. The ellipsis is shown at left side of the URL text.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.201412
Firmware Date          Mon Mar 30 20:14:21 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
Component: Gaia::Browser → Gaia::System::Browser Chrome
Whiteboard: [systemsfe]
Component: Gaia::System::Browser Chrome → Gaia::System
Nominating
blocking-b2g: --- → 2.2?
Priority: -- → P5
What is P5?
Flags: needinfo?(lebedel.delphine)
P5 is me hitting on the wrong button... ;) sorry, I meant P1 in this case
Flags: needinfo?(lebedel.delphine)
Priority: P5 → P1
(Assignee)

Comment 4

4 years ago
I'll take a look at this, I have an idea what's going on
Assignee: nobody → sfoster
(Assignee)

Comment 6

4 years ago
Comment on attachment 8586500 [details] [review]
[gaia] sfoster:card-view-ltr-subtitles-bug-1149448 > mozilla-b2g:master

Can you look at this Etienne? I deliberated over how/where to test it but settled on filing follow-up bug 1149858 to create tests for browser windows in card view.
Attachment #8586500 - Flags: review?(etienne)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8586500 [details] [review]
[gaia] sfoster:card-view-ltr-subtitles-bug-1149448 > mozilla-b2g:master

(In reply to Sam Foster [:sfoster] from comment #6)
> Comment on attachment 8586500 [details] [review]
> [gaia] sfoster:card-view-ltr-subtitles-bug-1149448 > mozilla-b2g:master
> 
> Can you look at this Etienne? I deliberated over how/where to test it but
> settled on filing follow-up bug 1149858 to create tests for browser windows
> in card view.

sounds good.

Wonder if this bug was also about page title for pages in ltr languages but I'm not sure we even have access to this information :/
Attachment #8586500 - Flags: review?(etienne) → review+
(Assignee)

Comment 8

4 years ago
Yeah we are running into a lot of these bidi cases. We'll want to step back and figure out the patterns at some point as we have had a lot of code that treats direction as binary - left or right.
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8586500 [details] [review]
[gaia] sfoster:card-view-ltr-subtitles-bug-1149448 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL / Task Manager
[User impact] if declined: URL is trunctated from wrong direction and ellipsis is at left in RTL locales
[Testing completed]: Verified on device
[Risk to taking this patch] (and alternatives if risky): Low risk, small change to task manager code
[String changes made]: None
Attachment #8586500 - Flags: approval-gaia-v2.2?
Attachment #8586500 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Assignee)

Updated

4 years ago
See Also: → 1150961
Target Milestone: --- → 2.2 S9 (3apr)
The fix only fixed the URL below title at card view, the rest of the issues are NOT fixed. This has failed verification.

See highlighted red in attached screenshots. The URL/title in browser itself and card view are still RTL when it should be LTR. Let me know if a separate bug needs to be filed.

Device: Flame 3.0
BuildID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(sfoster)
QA Whiteboard: [rtl-impact] → [rtl-impact][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact][failed-verification]
Flags: needinfo?(ktucker)
(Assignee)

Comment 13

4 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #12)
> Created attachment 8588708 [details]
> failed verification screenshots
> 
> The fix only fixed the URL below title at card view, the rest of the issues
> are NOT fixed. This has failed verification.
> 
> See highlighted red in attached screenshots. The URL/title in browser itself
> and card view are still RTL when it should be LTR. Let me know if a separate
> bug needs to be filed.

The patch I landed fixed the very specific bug that in task manager / tab view (card view), the URL beneath the title was RTL, when URLs should always be LTR and truncate from the right. 

Actually, I have a follow up for that in bug 1150961 you should be aware of as I broke hosted apps in card view. 

I see your point though about the titles - both in card view and browser. The document language might be RTL, but if the title area needs to support bididirectional text. Lets move this to a new bug and be really clear about the problem and criteria for a fix.
Flags: needinfo?(sfoster) → needinfo?(pcheng)
The original bug specifically stated that the browser URL/title should be LTR, though it seems like two bugs for me as well. I verified this bug based on what were expected on original writeup.

I've filed bug 1151925 for follow-up.
Flags: needinfo?(pcheng)
No longer blocks: browser-window-rtl, 1151925
Depends on: 1151925
(Reporter)

Comment 15

4 years ago
Per comment 29 and comment 31 in bug 1151925, this issue has been verified passed. Change the status to VERIFIED, FIXED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15466/
Flags: in-moztrap+
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][failed-verification] → [QAnalyst-Triage+][rtl-impact]
You need to log in before you can comment on or make changes to this bug.