Installed hosted apps show lock icon on empty line in task manager

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sfoster, Assigned: sfoster)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Missed in bug 1149448, 

STR: 
1. Install twitter (or other hosted app) from Marketplace
2. Open app
3. Long-press home button to show task manager

Expected: Task manager shows a single card with title 'Twitter' and nothing on the subtitle line below. 

Actual: The subtitle line has the lock icon on an empty line with no URL next to it.
(Assignee)

Comment 1

4 years ago
In bug 1149448, I added a child element to the .subTitle container to properly handle RTL and the LTR url we should in the subtitle. That means that the #cards-view .card p.subtitle:not(:empty) rule always matches here for secure hosted apps. 

Repros on master and v2.2 since 1149448 landed: requesting blocking status for this follow-up.
blocking-b2g: --- → 2.2?
(Assignee)

Comment 2

4 years ago
Patch in the works for this.
Assignee: nobody → sfoster
(Assignee)

Comment 4

4 years ago
Comment on attachment 8588194 [details] [review]
[gaia] sfoster:task-manager-lock-icon-hosted-apps-bug-1150961 > mozilla-b2g:master

The :empty selectors match always when I added the subtitle-url. Changed it up to add a show-subtitle class on the card. The unit tests were all using a http:// url which is the one case where we do want to show the url/subtitle which I think was not the intention for the non-browser case tests here, so I changed that to use app://.
Attachment #8588194 - Flags: review?(etienne)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8588194 [details] [review]
[gaia] sfoster:task-manager-lock-icon-hosted-apps-bug-1150961 > mozilla-b2g:master

All good! Sorry for the review delay.
Attachment #8588194 - Flags: review?(etienne) → review+
Whiteboard: [systemfe] → [systemsfe]
(Assignee)

Comment 6

4 years ago
Comment on attachment 8588194 [details] [review]
[gaia] sfoster:task-manager-lock-icon-hosted-apps-bug-1150961 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL (follow-up from bug 1149448)
[User impact] if declined: Hosted apps will show lock icon on empty line in card view
[Testing completed]: Tested on device, unit tests updated
[Risk to taking this patch] (and alternatives if risky): Low risk, this patches an issue introduced by incomplete solution in 1149448. We should ship both or neither. 
[String changes made]: None
Attachment #8588194 - Flags: approval-gaia-v2.2?
waiting for master landing here before addressing the branch uplift request.
(Assignee)

Comment 8

4 years ago
Merged to master: https://github.com/mozilla-b2g/gaia/commit/1192f05d1ce7027c5f6e6053b4f652ad29031466
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment #8588194 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
*v2.2
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0


*master
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.