Closed Bug 1149481 Opened 5 years ago Closed 4 years ago

Form select element with fractional width is cut off erratically

Categories

(Core :: Layout: Form Controls, defect)

36 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 429302

People

(Reporter: antonin.devel, Unassigned)

References

Details

Attachments

(2 files)

Attached file Reduced test case
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36

Steps to reproduce:

The options of a form select element with a fractional width will be cut off erratically (depending on viewport width) when the select element is placed within a horizontally centered block.

See the attached HTML file for a reduced test case.

This was seen on Firefox 32-36.0.4. (Not tested with earlier versions.)


Actual results:

A page contains a block element with an absolute width. This block element is horizontally centered within the body element via "margin-right/margin-left: auto;".

The block contains a select element with a fractional width, e.g. 33.333%.

When the viewport has an even width, the select's options are shown properly.

When the viewport has an odd width, the select's options are cut off on the right, which leaves them without right borders.

This happens only if the options are not wider than the select element.


Expected results:

The right borders on the select's options should be visible regardless of viewport width.
Attaching a screenshot of the select element's options being cut off.
Component: Untriaged → Layout: Form Controls
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
See Also: → 429302
Duplicate of bug: 429302
You need to log in before you can comment on or make changes to this bug.