Firefox /all/ download page now has Windows stubs instead of full installers

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kohei, Assigned: kohei)

Tracking

({regression})

Production
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1708370], URL)

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1129624 +++

Reported in #www by Philipp. Those stub installers have no problem in theory, but there are cases people are looking for full installers.

PR coming shortly.

Comment 1

3 years ago
We typically reserve the /firefox/all/ page for full installers, but that's not the case currently.

Will your PR change the windows URLs to non-stub links to d.m.o?
(Assignee)

Comment 2

3 years ago
(In reply to Chris More from comment #1)
> Will your PR change the windows URLs to non-stub links to d.m.o?

Yes, for English the link would be https://download.mozilla.org/?product=firefox-36.0-SSL&os=win&lang=en-US
(In reply to Chris More [:cmore] from comment #1)
> We typically reserve the /firefox/all/ page for full installers, but that's
> not the case currently.
> 
> Will your PR change the windows URLs to non-stub links to d.m.o?

Yes. That's the point of this. I think it was an unintended consequence of some recent refactoring that the links on /all/ were changed to stub instead of full installers.

Comment 4

3 years ago
thank you for fixing this. just as general note - we need to provide an easy way for people to get to the full installers for their language because sometimes the stub causes problems: https://support.mozilla.org/en-US/questions/firefox?tagged=stub-issue&show=all
(Assignee)

Comment 5

3 years ago
Created attachment 8586198 [details] [review]
pull request

Comment 6

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/8952c507ea42a63f5423192121e2186728f0130e
Fix Bug 1149620 - Firefox /all/ download page now has Windows stubs instead of full installers

https://github.com/mozilla/bedrock/commit/9fcd918f241157d8bbefc1a5f20b96363e84f89f
Merge pull request #2880 from kyoshino/bug-1149620-firefox-all-stub

Fix Bug 1149620 - Firefox /all/ download page now has Windows stubs instead of full installers

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
https://github.com/mozilla/mcom-tests/issues/396 covers adding a regression test for this, just FYI
Looks good
You need to log in before you can comment on or make changes to this bug.