Significant performance regression on the certain demo without HWA.

VERIFIED FIXED in Firefox 38

Status

()

Core
Graphics: Layers
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: milan)

Tracking

({perf, regression})

38 Branch
mozilla40
x86_64
Windows 7
perf, regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox37 unaffected, firefox38+ verified, firefox39+ verified, firefox40+ verified)

Details

(Whiteboard: gfx-noted, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Significant performance regression on the test[1] without HWA.

[1]https://developer.mozilla.org/media/uploads/demos/p/a/paulrouget/8bfba7f0b6c62d877a2b82dd5e10931e/hacksmozillaorg-achi_1334270447_demo_package/HWACCEL/

30fps+ on Firefox37 With HWA
  0fps on Firefox38 without HWA
(Reporter)

Comment 1

3 years ago
oops,
30fps+ on Firefox37.0 without HWA
  0fps on Firefox38b1 without HWA


Regression pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d94b6a6469b4&tochange=cbcafb38ad62
(Reporter)

Comment 2

3 years ago
Reproduced on windows7 Sp1 Windows8.1 update and Windows10TP10049.
Not reproduced on ubuntu14.04.
Not tested on Mac.

Via local build
Last Good: 08434d415b5c
First Bad: fcb277a52bdd

Regressed by:
fcb277a52bdd	George Wright — Bug 1042291 - Add a CanvasDrawObserver which observes the first few seconds/frames of a Canvas2D's lifetime to determine using a heuristic if it should be software or GPU backed. r=gw280, r=snorp


FYI,
Gecko profiler does not work well. Because if Gecko Profiler installed, the demo is working fine.
Blocks: 1042291
Component: General → Graphics: Layers
Flags: needinfo?(milan)
Keywords: regression
(Reporter)

Comment 3

3 years ago
It was fixed when it was in Aurora37.0a2 cycle (and maybe it was in Beta36 cycle). 
However, unfortunately, It has not been fixed in Nightly 38 and later.

Fixed range(aurora)
https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=5a89d54ef5e9&tochange=81a5207ffc75

Fixed by Bug 1124249 in in Aurora37.0a2 and Beta36 only
Depends on: 1124249
(Assignee)

Comment 4

3 years ago
I hate uplifts.  Bug 1124249 never landed in trunk (38 at the time.)  Will get a 38-40 patch.
Assignee: nobody → milan
Flags: needinfo?(milan)
Whiteboard: gfx-noted
(Assignee)

Comment 5

3 years ago
Created attachment 8586935 [details] [diff] [review]
Only Skia canvases need be considered for acceleration. Carry r=jmuizelaar from bug 1124249
Attachment #8586935 - Flags: review+
Tracking for 38+.  
Once we land this on m-c it would be good to get extra verification from QE.
tracking-firefox38: ? → +
tracking-firefox39: ? → +
tracking-firefox40: ? → +
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
(Assignee)

Comment 7

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f806e79f1c9a

After verification, I will ask for uplifts.
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/e6757cd28df3
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e6757cd28df3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Assignee)

Comment 10

3 years ago
Comment on attachment 8586935 [details] [diff] [review]
Only Skia canvases need be considered for acceleration. Carry r=jmuizelaar from bug 1124249

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: 13% of beta crashes.
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: We shouldn't be going into SkiaGL on the desktop, so this just enforces it.
[String/UUID change made/needed]: n/a

This got fixed in bug 1124249 during 38, but only landed on 36 and 37, and never on 38.  Now that it has landed on 40, we want to make sure we plug in the gap and land it on 38 and 39.  It already went through the previous beta as 37, so the risk should be small.
Attachment #8586935 - Flags: approval-mozilla-beta?
Attachment #8586935 - Flags: approval-mozilla-aurora?
I verified this fix on:

FF 40
Build id: 20150406030204
OS: Win 7 x64, Ubuntu 14.04 x64

However the verification on Mac Os X was not possible due to bug 1151492
Flags: needinfo?(florin.mezei)
Comment on attachment 8586935 [details] [diff] [review]
Only Skia canvases need be considered for acceleration. Carry r=jmuizelaar from bug 1124249

Fix a top crash, taking it. Should be in 38 beta 2 (likely) or 3 (worst case scenario)
Attachment #8586935 - Flags: approval-mozilla-beta?
Attachment #8586935 - Flags: approval-mozilla-beta+
Attachment #8586935 - Flags: approval-mozilla-aurora?
Attachment #8586935 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/95103b517141
status-firefox39: affected → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/b4e6da60e6d4
status-firefox38: affected → fixed
1fps using Firefox 38 beta 1 under Win 7 64-bit.
29+pfs using Firefox 38 beta 2
30fps with latest Aurora 39.0a2
29+fps with latest Nightly 40.0a1
Status: RESOLVED → VERIFIED
status-firefox38: fixed → verified
status-firefox39: fixed → verified
status-firefox40: fixed → verified
You need to log in before you can comment on or make changes to this bug.