media resource could no be decoded

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: t0mte-bugzilla, Unassigned, Mentored)

Tracking

({regression})

37 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox37 affected, firefox38 ?, firefox39 ?, firefox40 ?)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

SoundCloud no longer works on Siduction, no problems with FF 36.04. Plugins gstreamer0.10-ffmpeg and gstreamer1.0-libav are installed. For example, try this URL: https://soundcloud.com/aamourocean/yuntekkem



Actual results:

In the web console I get this:

Media resource https://cf-media.sndcdn.com/fPZ1VflpNoc2.128.mp3?Policy=eyJTdGF0ZW1lbnQiOlt7IlJlc291cmNlIjoiKjovL2NmLW1lZGlhLnNuZGNkbi5jb20vZlBaMVZmbHBOb2MyLjEyOC5tcDMiLCJDb25kaXRpb24iOnsiRGF0ZUxlc3NUaGFuIjp7IkFXUzpFcG9jaFRpbWUiOjE0Mjc4ODg5OTB9fX1dfQ__&Signature=oNoZOJ~1SFGtWJDKzO4tNOW9pcgpu9WIDkSrCeQ81OnLaJJWJMu0rBvewKnx~Dce36bPvcCPCjfovNSBE-CNXqcixoal6Rej4oUn07UeXrGLB2LWzRcqg86v33fMLMDhZMZpzxzvkaTZFIzM8nbW9yBA~dc42cAx3IMaUBLzUkkPK~KkgHuA~QEIPRbhkBo~ecR96~rgrS4Hs5DYSTeVpiWG4zk8GfAkzVUMzwVHHjCjcuzXCqxGRB~iM1fpSL4hTNUDIFoG6vbXS~qElItNiBuD6~J1rZUBL8Jctk3QxjrtqrStmyvvGXlj34Avxs9Pa9MOAhu-~C9ibfPw8aJFGA__&Key-Pair-Id=APKAJAGZ7VMH2PFPW6UQ could not be decoded.

Some terminal output:

(process:4326): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

** (firefox:4326): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed

Comment 1

4 years ago
Surely specific to Linux, I cannot reproduce it with FF37 on Win 7.

Could you use the tool mozregression to find a regression range (only the pushlog, no need to bisect), please.
See http://mozilla.github.io/mozregression/ for details.
Component: Untriaged → Video/Audio
Flags: needinfo?(t0mte-bugzilla)
Product: Firefox → Core
Reporter

Comment 2

4 years ago
Used mozregression --good-release 36 --bad-release 37
Got pushlog https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=332fa08016f8&tochange=ccdda35627df

If you need whole terminal output i could attach a logfile.
Flags: needinfo?(t0mte-bugzilla)

Comment 3

4 years ago
The suspected could be bug 1119302 as this Soundcloud page uses plugins to read MP3.
Component: Video/Audio → Plug-ins
Flags: needinfo?(benjamin)
Keywords: regression

Comment 4

4 years ago
Tomte-bugzilla, do you have any Firefox addons installed? If so, please try disabling them to see if that makes a difference.
Flags: needinfo?(benjamin) → needinfo?(t0mte-bugzilla)
Reporter

Comment 5

4 years ago
Just tested with a blank && fresh created user-profile without any addons installed: "media resource could no be decoded"
Flags: needinfo?(t0mte-bugzilla)

Comment 6

4 years ago
My team will not be working on this bug because it's not high-enough priority. I will provide some links to help a volunteer diagnose the problem if this is related to bug 1119302. If you have further questions, please feel free to NEEDINFO me.

The new call to check content-policy for plugin loads is at http://hg.mozilla.org/mozilla-central/annotate/70a113676b21/dom/plugins/base/nsPluginStreamListenerPeer.cpp#l502 

If you break at line 509 in a debugger, you can check `rv` and `shouldLoad` to see whether some content policy is rejecting the load. If that's the issue, then you'd have to go back and walk through that method and figure out which content policy is rejecting the load.
Mentor: benjamin

Updated

4 years ago
Reporter

Comment 7

4 years ago
Problem still exists in current beta => FF38.0

Comment 8

4 years ago
Of course because this regression appeared in FF37.

Comment 9

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID 	20160314030215
OS              Ubuntu 15.04

I tested this on latest Firefox release (v. 45) and latest Nightly (48.0a1) and could not reproduce the problem although I reproduced on Firefox 38. Considering I could reproduce on Firefox 38, but not on current release, I will mark this as Worksforme. If anyone can reproduce the issue on a current build fell free to reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.