If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FxOS] Add AudioOffloadPlayer support to save CPU power

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: sotaro, Assigned: bechen)

Tracking

(Blocks: 2 bugs)

37 Branch
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
MP4Reader does not support AudioOffloadPlayer. If  MP4Reader is enabled for local playback without supporting  AudioOffloadPlayer. It regress music playback time.
(Reporter)

Comment 1

3 years ago
The following is AudioOffloadPlayer related diagram.
https://github.com/sotaroikeda/firefox-diagrams/raw/master/media/dom_media_omx_AudioOffloadPlayer_FirefoxOS_2_2.pdf
(Reporter)

Comment 2

3 years ago
bwu, is there a bug like this already?
Flags: needinfo?(bwu)
(Reporter)

Updated

3 years ago
Blocks: 1123603
(Reporter)

Updated

3 years ago
No longer blocks: 1146729
(In reply to Sotaro Ikeda [:sotaro] from comment #2)
> bwu, is there a bug like this already?
No. Thanks for firing this bug!
Flags: needinfo?(bwu)
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Updated

2 years ago
See Also: → bug 1214208
Duplicate of this bug: 1188460
Summary: [FFOS] Add AudioOffloadPlayer support to MP4Reader → [FxOS] Add AudioOffloadPlayer support to save CPU power
Blocks: 1217384
(Assignee)

Comment 5

2 years ago
I think we need to
Assignee: nobody → bechen

Updated

2 years ago
blocking-b2g: --- → 2.6+
Priority: -- → P1

Comment 6

2 years ago
any news on this one?
Sorry. B2G is not our priority now.
blocking-b2g: 2.6+ → ---
Priority: P1 → --
(Assignee)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.