partial user matching is no longer working on review flags

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: froydnj, Assigned: glob)

Tracking

Production
x86_64
Linux

Details

Attachments

(1 attachment)

I've been submitting patches from git-bz for some time and using Bugzilla aliases (e.g. :froydnj) successfully to see review flags.  git-bz sets the requestee_type-4 field for chosen reviewers and POSTs directly to attachment.cgi.

Today, however, I've been getting failure messages from Bugzilla for certain users even when those users are valid.  Submitting patches with a reviewer of :dholbert and/or :mshal have both failed, even though confirming with Bugzilla (via CC field or assignee) that those people haven't removed their alias.  The error page I've been getting says:

    <td id="error_msg" class="throw_error">
    There is no user 
      named ':mshal'.
      Either you mis-typed the name or that user has not yet registered
      for a Bugzilla account.


    </td>

I'd say this is ~1 week old or so; CC'ing other people who I know use git-bz and might have noticed the same thing...
(Assignee)

Comment 1

3 years ago
(In reply to Nathan Froyd [:froydnj] [:nfroyd] from comment #0)
> I've been submitting patches from git-bz for some time and using Bugzilla
> aliases (e.g. :froydnj) successfully to see review flags.  git-bz sets the
> requestee_type-4 field for chosen reviewers and POSTs directly to
> attachment.cgi.

eww, that's nasty.
git-bz should be using our API instead of posting to our cgi's directly.  anything else is asking for trouble.

anyhow, this is a git-bz issue, please report it to their issue tracker on github: https://github.com/mozilla/git-bz-moz/issues
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

3 years ago
after investigating this some more, i can reproduce this issue with our ui.
it looks like partial user matching is failing.
Assignee: nobody → glob
Severity: normal → major
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: git-bz attachment submission via attachment.cgi complains incorrectly about unknown :$USER → partial user matching is no longer working on review flags
(Assignee)

Comment 3

3 years ago
Created attachment 8586849 [details] [diff] [review]
1150057_1.patch

- pass the matched username to _check_requestee instead of the substring
Attachment #8586849 - Flags: review?(dylan)
Comment on attachment 8586849 [details] [diff] [review]
1150057_1.patch

Review of attachment 8586849 [details] [diff] [review]:
-----------------------------------------------------------------

r=dylan

I never even knew you could set a review flag to just something like :dkl. Neat!
Attachment #8586849 - Flags: review?(dylan) → review+
Duplicate of this bug: 1150133
(Assignee)

Comment 6

3 years ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   a8248b8..1317be9  master -> master
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.