Remove nsMemory::Alloc/Free/Realloc from c-c following their removal in bug 1134920

RESOLVED FIXED in Thunderbird 40.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleth, Assigned: jcranmer)

Tracking

Thunderbird 40.0
x86
macOS
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
No description provided.
Assignee

Comment 1

4 years ago
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
Attachment #8586973 - Flags: review?(rkent)
Assignee

Comment 2

4 years ago
Note that I did not attempt to clean up header usage, since there are other things in nsMemory.h that are used in several of the files (particularly nsMemory::Clone and NS_FREE_*).

Comment 3

4 years ago
Hi,
I confirm that without this patch, the build of the latest tree I updated in the last 20 hours failed.
But with this patch, I could build C-C TB.

Thank you.
Comment on attachment 8586973 [details] [diff] [review]
Lots of automated sed changes

Looks good to me.
Attachment #8586973 - Flags: review?(rkent) → review+
Assignee

Comment 5

4 years ago
https://hg.mozilla.org/comm-central/rev/76d306801757
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0

Updated

4 years ago
Duplicate of this bug: 1150898
You need to log in before you can comment on or make changes to this bug.