[Contacts] After merging contacts, the merged contacts will still be counted when performing a Select All action.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: ferjm)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
After two contacts have been merged together, if the user performs a Select All action from Export Contacts or Delete Contacts, the number reported as being selected will be increased for each contact that had been merged.  This occurs even after the merged contact has been individually deleted.

If the user encounters this when choosing the Delete action, the progress bar will count the phantom contacts, indicating it is being deleted, however the extra contact will continue to persist afterwards.

If the user encounters this when choosing the Export action, the progress bar will only count real contacts, and no extra contacts are exported.

Closing and reopening the Contacts app appears resolve this issue, as extra contacts are no longer counted.

Repro Steps:
1) Update a Flame to 20150401010204
2) Launch the Contact app and ensure there are no existing contacts.
3) Create a new contact named "Test" with a phone number
4) Create a second new contact named "Contact" with the same phone number
5) Merge the two contacts together.
6) Tap the Gear icon to open settings, and select 'Delete Contacts'
7) Tap 'Select All'

Actual:
The header indicates '2 selected' when only one contact exists.

Expected:
The header accurately indicates '1 selected'

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: Video (URL), Logcat
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.2
The header indicates '2 selected' when only one contact exists.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150331002503
Gaia: cc11248ab69f13e89416c8e6bb2e184187e72088
Gecko: 90a26917ee8f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------

This issue does NOT occur on Flame 2.1
The header accurately indicates '1 selected'

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150326001202
Gaia: 6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gecko: e00ae73d67a2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression, looks like we're not updating the contacts list counter with how many contacts we have after merge events.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
Comms triage: Regression which can confuse an end user by showing the persistence of a merged contact.
blocking-b2g: 2.2? → 2.2+
See Also: → 1147787
(Assignee)

Updated

4 years ago
Attachment #8587477 - Flags: review?(francisco)
Removing window-wanted due to a patch has been submitted for review.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1151561
Seems to me that adding unit test is not the best way to testing this, do you think that we could add an integration test?
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 8

4 years ago
Yes, you are right. I just added the tests. Thanks!
Flags: needinfo?(ferjmoreno)
Comment on attachment 8587477 [details] [review]
[gaia] ferjm:bug1150220.merge.contacts > mozilla-b2g:master

Thanks for the test.
Attachment #8587477 - Flags: review?(francisco) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/d593ab30e6e2c3299f56320f8804adf2e9d077ab
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8587477 [details] [review]
[gaia] ferjm:bug1150220.merge.contacts > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression cause of performance patch
[User impact] if declined:
Bad user experience
[Testing completed]:
Tested on master, added integration test
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
None
Attachment #8587477 - Flags: approval-gaia-v2.2?
Target Milestone: --- → 2.2 S10 (17apr)
Attachment #8587477 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Keywords: verifyme
Verified that the issue has been fixed on 2.2 and 3.0. Following STR at comment 0, the device no longer displays 2 contacts selected when there's only one.

However bug 1151561 that was marked duplicate to this one is NOT fixed on 2.2 and 3.0. Un-duping the duplicated bug.

Device: Flame 2.2
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150414072436
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 388f5861dc7d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.