[Flame][Camera]The page will skip the preview view and video mode, but directly back to photo mode.

RESOLVED DUPLICATE of bug 1153776

Status

defect
RESOLVED DUPLICATE of bug 1153776
4 years ago
4 years ago

People

(Reporter: wangxin, Assigned: mikeh)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 affected, b2g-master unaffected)

Details

Attachments

(3 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame][v2.2][Camera]Share a video from video preview page to Message, and then the delivery will fail because the attachment is too large, then press the OK button, the page will skip the preview view and video mode, but directly back to photo mode.
Found time: 15:01
See log:"logcat_1501.txt"
See video:"1501.mp4"

[2.Testing Steps]: 
1 Launch "Camera".
2. Switch to "Video" mode.
3. Record a video more than 300KB  and go to preview page.
4. Tap the share icon and share it by  Message.
5. When the message prompt the attachment is too large, then tap the "OK" button.

[3.Expected Result]: 
5. The page should back to preview page.

[4.Actual Result]: 
5. The page will back to Camera and in Photo mode.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150401002624

Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4

Gaia Date              2015-03-31 21:48:06

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150401.042225

Firmware Date          Wed Apr  1 04:22:36 EDT 2015

Bootloader             L1TC000118D0

Flame 3.0(unaffected):
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video Bug video: 1501.MP4
Reporter

Updated

4 years ago
Hi, SandKing,

Can it be reproduced with the latest v2.1 build?
Flags: needinfo?(wangxin)
Reporter

Comment 3

4 years ago
This issue not exists on latest v2.1 and v2.1s,
STR as comment 0
Repro rate: 0/10

V2.1 build(affected):
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0

V2.1S_510M(unaffected):
Build ID               20150406001206
Gaia Revision          fa9fb90a3eaad9feff807249a925926626287908
Gaia Date              2015-03-25 15:44:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/1cb38d8d878f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
Flags: needinfo?(wangxin)
Reporter

Comment 4

4 years ago
(In reply to SandKing from comment #3)

Sorry, affected should change to unaffected, Both v2.1 and v2.1s are unaffected.
> V2.1 build(affected):
> Build ID               20150406001204
> Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
> Gaia Date              2015-04-03 21:43:01
> Gecko Revision        
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
> Gecko Version          34.0
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150406.034925
> Firmware Date          Mon Apr  6 03:49:36 EDT 2015
> Bootloader             L1TC000118D0
Thanks SandKing.
--- -- - --- -- - --- -- - --- -- -
A regression. Inconsistent behavior between releases.
Suggest to improve it.
blocking-b2g: --- → 2.2?
Keywords: regression
djf/Hema can you check this issue ? Was this behavior changed for 2.2 by any chance ?
Flags: needinfo?(hkoka)
Flags: needinfo?(dflanagan)

Comment 7

4 years ago
I don't remember any changes here. Adding Russ and Justin too to see if they are aware.
Flags: needinfo?(rnicoletti)
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(hkoka)
I happen to have a 2.1 build on my flame right now, and can confirm that in 2.1, we return to the preview mode of the camera.

My guess about what is happening here is that the camera app is being killed by OOM while the messaging app is open, and then when we return to it it starts up in its default state.  The attached logcat does show the camera starting up twice.

On the other hand, the sms app treats the share activity as inline, so I thought that the system was supposed to keep both the camera and sms apps alive.  Maybe that has changed in the system app. 

Needinfo for Alive to see if this is a change in 2.2: can the app that initiates an inline activity be killed during the activity and then automatically restarted when the activity ends?

Needinfo for SandiKing: how much memory was your device configured with when you found this bug? Does the bug go away if you use a 512mb or 1024mb device?

If this is an OOM, then I'm not sure there is anything we can do about it.

If it is not an OOM, then Justin is probably the right one to investigate. Justin: have there been any changes to the activity handling code in Camera between 2.1 and 2.2?  This is completely unrelated to the Video app, so I doubt that Russ will have anything to add here.
Flags: needinfo?(wangxin)
Flags: needinfo?(dflanagan)
Flags: needinfo?(alive)
On the other hand, when I watch the video, I see that when we leave the sms app, the camera preview mode is briefly shown and then disappears and a spinner appears and the camera controls fade in.

So if my OOM theory is right, it means that the window manager is displaying a screenshot of the dead app and then restarting it.

I notice that in 2.1, if I have camera and another app running and am in camera app preview mode and then swipe with an edge gesture to switch to the other app and switch back, the camera leaves preview mode and returns to the viewfinder. Is that intentional behavior? If so, then maybe the 2.2 behavior is also intentional?  (Leaving video mode clearly seems wrong, though, so that, at least, is probably a bug.)

I we should also take a look at the dmesg log for this bug to get confirmation of whether an OOM is occurring.
I haven't been able to investigate this on my device yet, but from watching the video, I have to agree with David in comment 9 that this looks like an OOM. In addition to the reason he gave about seeing a screenshot of the dead app and restarting, you'll also notice that no preview thumbnail is present in the Camera app upon returning. This is also an indicator that the Camera app you're returning to is not the same instance that you were in when you started (killed and re-started).
ni?ing on myself to check out and produce gecko log
Flags: needinfo?(npark)
I don't have anything to add regarding information related to the video app. However, I have three observations: 1) When following the STR except choosing 'email' instead of 'message' and choosing 'cancel' at the "mail is not setup" dialog, the user is also brought back to the photo mode. However, the thumbnail of the video that had just been recorded is still present. When returning to the photo mode after sharing with "messages", the thumbnail of the video that was just recorded is no longer there. To my understanding, that supports the OOM theory for this bug. Except, my third observation is the PID of the camera app does not change after following the STR. Wouldn't we expect it to change if the app was restarted after an OOM event?
Flags: needinfo?(rnicoletti)
(In reply to Russ Nicoletti [:russn] from comment #12)
> I don't have anything to add regarding information related to the video app.
> However, I have three observations: 1) When following the STR except
> choosing 'email' instead of 'message' and choosing 'cancel' at the "mail is
> not setup" dialog, the user is also brought back to the photo mode. However,
> the thumbnail of the video that had just been recorded is still present.
> When returning to the photo mode after sharing with "messages", the
> thumbnail of the video that was just recorded is no longer there. To my
> understanding, that supports the OOM theory for this bug. Except, my third
> observation is the PID of the camera app does not change after following the
> STR. Wouldn't we expect it to change if the app was restarted after an OOM
> event?

It is interesting that you observed that the PID doesn't change. I *think* that means that this is not actually an OOM, but I could be wrong. If its not, then its possible that it is following a code path that's causing a `window.location.reload()`:

https://github.com/mozilla-b2g/gaia/blob/master/apps/camera/js/app.js#L232
Reporter

Comment 14

4 years ago
(In reply to David Flanagan [:djf] from comment #8)

> Needinfo for SandiKing: how much memory was your device configured with when
> you found this bug? Does the bug go away if you use a 512mb or 1024mb device?

Hi David,
My device is configured with 319M when I find this bug. And this bug still exists if I use a 512mb or 1024mb device.
Flags: needinfo?(wangxin) → needinfo?(dflanagan)
I don't see there is anyone being killed during the progress. BTW, what is the preview page? Is it part of camera app?

"[AppWindow][Camera][AppWindow_5][1263.829]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1265.953]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1267.378] preprocessing touch event...,touchstart" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1267.379] processing touch event...,touchstart" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1267.455] preprocessing touch event...,touchend" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1267.456] processing touch event...,touchend" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1267.457] releasing statusbar" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1269.026]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1269.312] Camera:AppWindow_5 is setting nfc active to: false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1270.444] publishing internal event: launchactivity" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][undefined][1270.447] publishing external event: creating" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][undefined][1270.450] publishing external event: willrender" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.497] adding mozbrowserclose event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.498] adding mozbrowsererror event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.498] adding mozbrowservisibilitychange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.499] adding mozbrowserloadend event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.499] adding mozbrowseractivitydone event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.500] adding mozbrowserloadstart event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.500] adding mozbrowsertitlechange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.501] adding mozbrowserlocationchange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.502] adding mozbrowsermetachange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.505] adding mozbrowsericonchange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.507] adding mozbrowserasyncscroll event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.507] adding mozbrowsersecuritychange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.508] adding _localized event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.509] adding _swipein event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.510] adding _swipeout event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.510] adding _kill_suspended event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.511] adding _orientationchange event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.511] adding _focus event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.512] adding _blur event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.512] adding _hidewindow event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.513] adding _sheetdisplayed event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.513] adding _sheetsgestureend event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.513] adding _cardviewbeforeshow event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.514] adding _cardviewclosed event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.514] adding _cardviewshown event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.515] adding _closed event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.515] adding _shrinkingstart event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.516] adding _shrinkingstop event handler ..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.516] installing sub components..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.518] default animation:,fade-in,fade-out" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.529] publishing internal event: rendered" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.530] publishing external event: rendered" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.531] publishing internal event: created" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.532] publishing external event: created" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.539] open with fade-in" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.540] closed,opening,::,open" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.542] timer to ensure opened does occur." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.544] appWindow activityWindow inline-activity fullscreen-app transition-opening fade-in" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.545] publishing internal event: opening" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.546]  fade in <<<<< " "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.546] publishing internal event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.547] publishing external event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.548] handling _opening" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.549] publishing external event: opening" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.550] publishing internal event: willopen" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.550] publishing external event: willopen" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1270.552] aria-hidden on browser element:true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.615]  Handling mozbrowserloadstart event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.616] publishing internal event: loading" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.617] publishing external event: loading" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.630]  Handling mozbrowserlocationchange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.631] publishing internal event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.632] publishing external event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.643]  Handling mozbrowsersecuritychange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.644] publishing internal event: securitychange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1270.645] publishing external event: securitychange"insecure"" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1270.840] Camera:AppWindow_5 is setting nfc active to: true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.060] publishing internal event: openingtimeout" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.061] opening,opened,::,timeout" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.063] publishing internal event: opened" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.065] publishing internal event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.066] publishing external event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.070] focusing this app." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.088] Messages:ActivityWindow_2 is setting nfc active to: true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.118] publishing external event: opened" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.161] publishing internal event: open" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.162] publishing external event: open" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.459]  Handling mozbrowsermetachange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.460] publishing internal event: themecolorchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.461] publishing external event: themecolorchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.470]  Handling mozbrowsertitlechange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.471] publishing internal event: titlechange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.472] publishing external event: titlechange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.988] publishing internal event: chromecollapsed" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1271.989] publishing external event: chromecollapsed" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.712]  Handling mozbrowserloadend event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.714] publishing internal event: loadtime" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.715] publishing external event: loadtime{"time":2169,"type":"c","src":"app://sms.gaiamobile.org/index.html#activity-share"}" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.717] publishing internal event: loaded" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.720] publishing external event: loaded" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.725] bgcolor= ,rgb(255, 255, 255)" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1272.727] setting background color.." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1273.252] publishing internal event: inputmethod-contextchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1273.253] handling _inputmethod-contextchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1273.466]  Handling mozbrowsersecuritychange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1273.467] publishing internal event: securitychange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1273.470] publishing external event: securitychange"insecure"" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.049] request RESIZE...active? ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.051] force RESIZE..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.051] publishing internal event: withkeyboard" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.054] publishing internal event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.060] publishing external event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.061] W:,320,H:,364.6666666666667" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.062] request RESIZE...active? ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.062]  will resize... " "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.063] force RESIZE..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.063] publishing internal event: withkeyboard" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.065] publishing internal event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.066] publishing external event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.067] W:,320,H:,364.6666666666667" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.295]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1274.297]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1274.335]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1278.924] preprocessing touch event...,touchstart" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1278.930] processing touch event...,touchstart" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.038] preprocessing touch event...,touchend" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.039] processing touch event...,touchend" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.075] releasing statusbar" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.189] request RESIZE...active? ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.191] force RESIZE..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.191] publishing internal event: withoutkeyboard" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.198] publishing internal event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.198] publishing external event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.199] W:,320,H:,569.3333333333334" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.200] request RESIZE...active? ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.201]  will resize... " "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.201] force RESIZE..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.202] publishing internal event: withoutkeyboard" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.204] publishing internal event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.205] publishing external event: resize" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.206] W:,320,H:,569.3333333333334" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.230] publishing internal event: inputmethod-contextchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.230] handling _inputmethod-contextchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.241] aria-hidden on browser element:false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1279.541]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1279.673]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.357]  Handling mozbrowserasyncscroll event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.450]  Handling mozbrowseractivitydone event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.462] close with fade-out" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.463] opened,closing,::,close" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.464] timer to ensure closed does occur." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.465] publishing internal event: closing" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.467] handling _closing" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.467] aria-hidden on browser element:false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.470]  locking screen orientation to default" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.471] publishing internal event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.474] publishing external event: requestforeground" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.476] set visibility -> ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.477] setActive on browser element:true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.497] before showing frame" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.498] set visibility -> ,true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.498] setActive on browser element:true" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.501] before showing frame" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.503] aria-hidden on browser element:false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.528] publishing external event: closing" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.529] publishing internal event: willclose" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.530] publishing external event: willclose" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.531] publishing internal event: terminated" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.532] publishing external event: terminated" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.556]  Handling mozbrowserloadstart event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.557] publishing internal event: loading" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.558] publishing external event: loading" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.659]  Handling mozbrowsersecuritychange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.659] publishing internal event: securitychange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.660] publishing external event: securitychange"insecure"" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.671]  Handling mozbrowserlocationchange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.672] publishing internal event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.673] publishing external event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.928]  Handling mozbrowsermetachange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.929] publishing internal event: themecolorchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.933] publishing external event: themecolorchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.951]  Handling mozbrowsertitlechange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.952] publishing internal event: titlechange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1281.953] publishing external event: titlechange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.970]  Handling mozbrowserlocationchange event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.971] publishing internal event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1281.972] publishing external event: locationchange" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.005] close with immediate" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.005] closing,closed,::,immediate-close" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.008] publishing internal event: closed" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.009]  Handling _closed event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.033] set visibility -> ,false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.034] setActive on browser element:false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.065] before hiding frame" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.065] setVisible on browser element:false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.069] Messages:ActivityWindow_2 is setting nfc active to: false" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.073] publishing internal event: willdestroy" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.074] publishing external event: willdestroy" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.098] publishing external event: destroyed" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[ActivityWindow][Messages][ActivityWindow_2][1282.122] publishing external event: closed" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1282.519]  Handling mozbrowserloadend event..." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1282.521] publishing internal event: loaded" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1282.526] publishing external event: loaded" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1282.527] bgcolor= ,rgb(0, 0, 0)" "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)" app_window.js:1136:0
"[AppWindow][Camera][AppWindow_5][1282.531] setting background color.." "
    at aw_debug (app://system.gaiamobile.org/js/app_window.js:1136:0)"
Flags: needinfo?(alive)
Posted file 1150445.log
I can repro the bug in 2.2 build (logcat attached) but I couldn't find the evidence of OOM in the log, plus the UI action is too smooth to be an OOM issue.  In most (not all) cases, OOM does involve abrupt window termination and brief appearance of blank background image.  It looks to me (totally a guess here) that when the message app is closed and the context is returning to the Camera app, camera app did not remember where it left off so starts from the beginning.
Flags: needinfo?(npark)
Russ: thanks for testing this with email. That's curious that the behavior is different in those two cases. Thanks also for thinking to check the process ids. That pretty clearly rules out my OOM hypothesis.

Justin: I'd forgotten about the camera app "rebooting" itself with a reload

No-Jun: I didn't see an OOM for sure. What I saw in the original attached logcat was evidence that the camera app was loaded twice (two sets of startup debug messages). And that is consistent with the "reboot" scenario Justin describes.

Mike: app.js:522 reloads the app when a share activity succeeds and calls app.setSharingState('not-sharing'); (see controllers/preview-gallery.js:163)  Git blame says that this code is yours from bug 1102675. Do you have time to take this and fix it here, or should we find someone else to work on it?
Blocks: 1102675
Flags: needinfo?(dflanagan) → needinfo?(mhabicher)
Just based on reading the code, I'm guessing that the email app must do a postError() and trigger the onerror function in preview-gallery.js, and in that case no reboot happens. But the message app actually sends postResult even in the error case, and that triggers the reboot?  Though if that is the case we would expect to see the reboot after any normal share activity.
Okay, I've flashed 2.2 and have verified that this bug isn't specific to the message app, or to video. Any share activity that completesly normally causes the reboot.

That means that if you take 3 photos and share one via sms (or even set it as your wallpaper) then when you come back to the camera, it reloads itself, and you lose the ability to share the other two photos because your preview gallery is gone.

That is not quite data loss since the photos are still on your phone, but it is pretty bad. I'm going to go ahead and make this a blocker, since it is a regression caused by a 2.2+ bug.

Looks like the offending patch only landed on 2.2, so that is the only branch that needs to be fixed.

Mike: did the
blocking-b2g: 2.2? → 2.2+
Oops. Ignore the "Mike: did the" part of the comment above. I answered my own question about what branches are involved.
djf, the .reload() call[1] was in there to restart the Camera app if the activity was cancelled, because something wasn't working right when the activity was just cancelled instead of completing successfully. I don't remember the exact reason.

1. https://github.com/mozilla-b2g/gaia/commit/1431bc1d5b7f8c0426d0f80c30a24528828650d2#diff-611b9e5fc33d8d5655497e81dd1a9c32R522

I'll take a look at this.
Flags: needinfo?(mhabicher)
One thing to note: I ran this scenario on a debug build, which is much slower than the regular build.  The bug was not reproducible in this case though, suggesting maybe that it's something to do with the timing?
Thanks, Mike. It looks to me like your logic is causing the restart when the activity is successful...

I've taken the liberty of assigning this to you based on comment 21. Since it is a blocker, I don't want it to be unowned.
Assignee: nobody → mhabicher
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1153776
Clearing NI? since this has been resolved.
Flags: needinfo?(jdarcangelo)
You need to log in before you can comment on or make changes to this bug.