[Camera][Flame] If we share a picture then enter card view and switch back to the Camera app, the viewfinder is black

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Camera
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: SandKing, Assigned: mikeh)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8591567 [details]
Bug log: logcat_0526.txt

[1.Description]:
[Flame][v2.2][Camera]When"Selt-Timer" mode was enabled, take a picture, share it and  enter card view , then back to camera, you can see the viewfinder will turn black.
Found time:05:26
See log:"logcat_0526.txt"
See video:"0526.mp4"

[2.Testing Steps]: 
1. Launch Camera.
2. Press Menu button to enable "Self-Timer"(2s 5s 10s).
3. When Self-Timer is enabled, take a picture.
4. Go to preview page, and share this picture.
5. Share picture with one of the item( I use Wallpaper).
6. In wallpaper preview page(don't choose Cancel or Set button), Long press Home key to enter card view.
7. Back to Camera from card view.
8. Choose the "Cancel" button.

[3.Expected Result]: 
8. You can see image through the view finder.

[4.Actual Result]: 
8. The viewfinder was dark.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.040730
Firmware Date          Sun Apr 12 04:07:41 EDT 2015
Bootloader             L1TC000118D0

Flame3.0(Unaffected):
Build ID               20150412160203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.192808
Firmware Date          Sun Apr 12 19:28:21 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8591570 [details]
Bug video: 0526.MP4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
Regression, broken functionality. 
ni RD.
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(mhabicher)
Keywords: regression
Blocks: 1102675
Flags: needinfo?(mhabicher)
I just tested the STR with:

Gaia-Rev        5d0c16cc8a50c5b3b1cd19cf1b0b9e367fe0a5e4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/41388836b5c6
Build-ID        20150416002504
Version         37.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0

...and have confirmed the observed result.

This viewfinder only resumes as black if the switch to card view takes place; otherwise, just cancelling the Share activity does not result in a black viewfinder.

Also, Self-Timer mode is not required; this happens when taking pictures normally as well.

STR:
1. Launch Camera.
2. Take a picture.
3. Go to preview page, and share this picture.
4. Share picture with one of the item( I use Wallpaper).
5. In wallpaper preview page(don't choose Cancel or Set button), Long press Home key to enter card view.
6. Back to Camera from card view.
7. Choose the "Cancel" button.
Summary: [Flame][Camera]If we share a picture which is taken in" Selt-Timer" mode and enter card view , then back to camera, the viewfinder will turn black. → [Camera][Flame] If we share a picture then enter card view and switch back to the Camera app, the viewfinder is black
Created attachment 8593546 [details] [review]
[gaia] mikeaich:bug1153776 > mozilla-b2g:v2.2
Attachment #8593546 - Flags: review?(jdarcangelo)
Comment on attachment 8593546 [details] [review]
[gaia] mikeaich:bug1153776 > mozilla-b2g:v2.2

LGTM
Attachment #8593546 - Flags: review?(jdarcangelo) → review+
Attachment #8591567 - Attachment is obsolete: true
Attachment #8591570 - Attachment is obsolete: true
Comment on attachment 8593546 [details] [review]
[gaia] mikeaich:bug1153776 > mozilla-b2g:v2.2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1102675
User impact if declined: see comment 0
Testing completed:
1. open camera app > take picture > tap thumbnail to open Preview > tap Share button > Wallpaper > cancel --> returns to Preview > press back button --> Camera viewfinder works properly
2. open camera app > take picture > tap thumbnail > tap Share button > Wallpaper > press and hold Home button > select Camera app > cancel --> returns to Preview > press back button --> Camera viewfinder works properly
3. open camera app > take picture > tap thumbnail > tap Share button > Messages > tap attach button > Camera > press Home button > tap Camera icon --> activity Camera viewfinder works properly > tap "X" button --> returns to Preview > tap back button --> Camera viewfinder works properly
Risk to taking this patch (and alternatives if risky): low, but there may be corner cases which testing has not yet revealed
String or UUID changes made by this patch: none
Attachment #8593546 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
blocking-b2g: --- → 2.2+

Updated

3 years ago
Keywords: checkin-needed, verifyme

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29552

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Comment on attachment 8593546 [details] [review]
[gaia] mikeaich:bug1153776 > mozilla-b2g:v2.2

Please verify on 2.2 once this lands on b2g37
Attachment #8593546 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29552

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Pull request has landed in v2.2: https://github.com/mozilla-b2g/gaia/commit/c15a2b6d3a783813959c2b3bffd2a131f4270b9e

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1150445
Assignee: nobody → mhabicher
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
(Reporter)

Comment 12

3 years ago
This issue has been verified successfully on Flame2.2
STR:
Same STR with comment0 and comment3.

Flame 2.2(Pass):
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.