If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][Homescreen]User can't scroll the screen in smart collection page.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Everything.me
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Assigned: kgrandon)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8587319 [details]
video_0725.mp4

[1.Description]:
[Flame][v2.2 & v3.0][Homescreen]User can't scroll the screen if they tap a blank area and slide up and down.
Found time:07:25
See attachment:Locat_0725.txt & video_0725.mp4

[2.Testing Steps]: 
1.Open social collection.
2.Move some icon to up of line.
3.Press on blank area and then slide.

[3.Expected Result]: 
3.User can scroll the screen easily.

[4.Actual Result]: 
3.User can't scroll the screen.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150401002624

Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4

Gaia Date              2015-03-31 21:48:06

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150401.042225

FirmwareDate           Wed Apr  1 04:22:36 EDT 2015

Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8587320 [details]
logcat_0725.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Comment 2

3 years ago
Interesting bug.

--- -- - --- -- - --- -- -
Hi, Verson,

Can it be reproduced with the latest v2.1 build?
Many thanks.
Flags: needinfo?(xiongfuchao)
(Reporter)

Comment 3

3 years ago
Created attachment 8588875 [details]
verify2.1.mp4

Hi, William,

This bug can't be reproduced on latest v2.1 build,The STR is same as Comment 0.
Reproduce rate:0/5
See attachment:verify2.1.mp4

Build version:
Flame 2.1(Unaffected):
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(xiongfuchao)
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected

Comment 4

3 years ago
A regression.
Inconsistent behavior and unresponsive touch event.
blocking-b2g: --- → 2.2?
Keywords: regression
Kats, any idea where this is coming from?
Flags: needinfo?(bugmail.mozilla)
blocking-b2g: 2.2? → 2.2+
Keywords: regressionwindow-wanted
Flags: needinfo?(nhirata.bugzilla)
QA Contact: pcheng
Initial investigation seems to indicate that it's a Gaia bug, possibly one that is now exposed since we fixed a bunch of stuff in platform in 2.2. The container holding the icons (which is the scrollable thing) doesn't have a background, so when you tap in the empty space you're actually tapping on the background behind the scrolling div, and dragging that around won't do anything.
Flags: needinfo?(bugmail.mozilla)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Initial investigation seems to indicate that it's a Gaia bug, possibly one
> that is now exposed since we fixed a bunch of stuff in platform in 2.2. The
> container holding the icons (which is the scrollable thing) doesn't have a
> background, so when you tap in the empty space you're actually tapping on
> the background behind the scrolling div, and dragging that around won't do
> anything.

Thanks Kats!
Kevin, can you take a look here?
Flags: needinfo?(kgrandon)
Whiteboard: [systemsfe]
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150310161731
Gaia: 2bcb2253c3a98a6f5b4c4f6360984fd61bcb9d45
Gecko: c29d7a6f5e4f
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150310170527
Gaia: 6f45c01746a2d0aeae63e68e1d4e5aa465a02f94
Gecko: 67a4f6acff23
Version: 39.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 2bcb2253c3a98a6f5b4c4f6360984fd61bcb9d45
Gecko: 67a4f6acff23

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 6f45c01746a2d0aeae63e68e1d4e5aa465a02f94
Gecko: c29d7a6f5e4f

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/2bcb2253c3a98a6f5b4c4f6360984fd61bcb9d45...6f45c01746a2d0aeae63e68e1d4e5aa465a02f94

Caused by Bug 1120884.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Chris, can you take a look at this please? Looks like this may have been caused by the work done for bug 1120884.
Blocks: 1120884
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(chrislord.net)
(Assignee)

Comment 10

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #8)
> b2g-inbound regression window:
> // SNIP
> Gaia pushlog:
> https://github.com/mozilla-b2g/gaia/compare/
> 2bcb2253c3a98a6f5b4c4f6360984fd61bcb9d45...
> 6f45c01746a2d0aeae63e68e1d4e5aa465a02f94
> 
> Caused by Bug 1120884.

This regression range seems incorrect. I reverted to a previous gaia commit, and the issue reproduced on the same gecko. This is likely a gecko bug causing this.
(Assignee)

Updated

3 years ago
No longer blocks: 1120884
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 11

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Initial investigation seems to indicate that it's a Gaia bug, possibly one
> that is now exposed since we fixed a bunch of stuff in platform in 2.2. The
> container holding the icons (which is the scrollable thing) doesn't have a
> background, so when you tap in the empty space you're actually tapping on
> the background behind the scrolling div, and dragging that around won't do
> anything.

I checked, and we currently have a overflow-y: scroll on the #content div. The icons are inside of a web component in that div. If you have two icons on the last row, some icons and some empty area inside of #content, you can scroll by starting to scroll on the icons, but not the empty space.

Kats - the #content is a rectangle, which is transparent in some areas if we don't have icons. Shouldn't you be able to scroll if you start scrolling on a transparent div? I'm still touching inside of the #content div, and wondering why the touch is going "through" it?
Flags: needinfo?(kgrandon) → needinfo?(bugmail.mozilla)
(Assignee)

Comment 12

3 years ago
I think that maybe we are calculating the height of the gaia-grid wrong. I still feel that there is a platform bug here in that we should either not allow scrolling on things outside the height, independently of the background color. Something is weird, but I think we can work around this in gaia for now.
Flags: needinfo?(bugmail.mozilla)
(Assignee)

Updated

3 years ago
Component: Gaia::Homescreen → Gaia::Everything.me
(Assignee)

Updated

3 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED

Comment 13

3 years ago
Created attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master
(Assignee)

Comment 14

3 years ago
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

Here is a patch which seems to fix the issue. I think at some point code got migrated to set the height in the home screen for grouping, but we forgot about collections. Chris - could you take a look if you get a chance? Thanks!
Attachment #8589348 - Flags: review?(chrislord.net)
I re-checked my last working build and discovered that scrolling doesn't work on empty space on last row, but it works everywhere else. I can try to find a window where scrolling on last row doesn't work if it's desired.
If you think there is still an outstanding platform issue please file a follow-up bug, ideally with a standalone test case.
Kevin's patch works.  The only thing I would comment on the patch that is if you clear the bottom row of apps at the lower half, you have one row of empty.  Not a huge deal, considering it doesn't look broken any more.

I think we're just waiting for Chris to review so Kevin can land.
Flags: needinfo?(nhirata.bugzilla)
(Assignee)

Comment 18

3 years ago
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

Oh, maybe Chris is out? Dale - if you have some cycles, could you review this? Thanks!
Attachment #8589348 - Flags: review?(dale)
Target Milestone: --- → 2.2 S10 (17apr)
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

This looks good, cheers Kevin
Attachment #8589348 - Flags: review?(dale) → review+
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

This looks good, cheers Kevin
(Assignee)

Comment 21

3 years ago
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

Thanks!
Attachment #8589348 - Flags: review?(chrislord.net)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 22

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/9e8b2f2b54aada3858f1629f11c8276ff5c2adb1

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
status-b2g-master: affected → fixed
(Assignee)

Comment 23

3 years ago
Comment on attachment 8589348 [details] [review]
[gaia] KevinGrandon:fix_bug_1150464 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Likely surfaced by some platform change.
[User impact] if declined: Poor UX when scrolling collections.
[Testing completed]: Manual testing (small layout change)
[Risk to taking this patch] (and alternatives if risky): Low risk, contained to collections.
[String changes made]: None.
Attachment #8589348 - Flags: approval-gaia-v2.2?(bbajaj)
Just a note about the fix, the height is in the detail of the message, you don't need to peek into the grid's layout (here's the handling code in verticalhome: https://github.com/mozilla-b2g/gaia/blob/master/apps/verticalhome/js/app.js#L250).

No biggie, but something we may want to tidy up at some point.

Updated

3 years ago
Attachment #8589348 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/849e9b28cdc4741fdb915a05bc5d63da8cfeb484
status-b2g-v2.2: affected → fixed
Flags: needinfo?(hcheng)
This issue is verified fixed on Flame 3.0 and 2.2. Scrolling on empty space in a smart collection works, even on the area that I mentioned at comment 15.

Device: Flame 3.0
BuildID: 20150414072436
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 388f5861dc7d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(hcheng)
Depends on: 1157895

Updated

2 years ago
No longer depends on: 1157895
You need to log in before you can comment on or make changes to this bug.